summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-03-15 11:38:29 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-03-15 11:43:20 +0100
commitad34eb222c9ebc2b31f03b70ba6655ebe8ee74b5 (patch)
treeb2c3174262a3ba7c8fb57c0d1c32988b152bf572 /gnu
parentc20813bb08d19d424a5965da467599284adad8fc (diff)
downloadguix-patches-ad34eb222c9ebc2b31f03b70ba6655ebe8ee74b5.tar
guix-patches-ad34eb222c9ebc2b31f03b70ba6655ebe8ee74b5.tar.gz
gnu: Add python-drep.
* gnu/packages/bioinformatics.scm (python-drep): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index b2d10457fe..c629b79c39 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -13147,6 +13147,36 @@ create connections between analogous cells in different batches without
altering the counts or PCA space.")
(license license:expat)))
+(define-public python-drep
+ (package
+ (name "python-drep")
+ (version "3.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "drep" version))
+ (sha256
+ (base32
+ "08vk0x6v5c5n7afgd5pcjhsvb424absypxy22hw1cm1n9kirbi77"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-biopython" ,python-biopython)
+ ("python-matplotlib" ,python-matplotlib)
+ ("python-numpy" ,python-numpy)
+ ("python-pandas" ,python-pandas)
+ ("python-pytest" ,python-pytest)
+ ("python-scikit-learn" ,python-scikit-learn)
+ ("python-seaborn" ,python-seaborn)
+ ("python-tqdm" ,python-tqdm)))
+ (home-page "https://github.com/MrOlm/drep")
+ (synopsis "De-replication of microbial genomes assembled from multiple samples")
+ (description
+ "dRep is a Python program for rapidly comparing large numbers of genomes.
+dRep can also \"de-replicate\" a genome set by identifying groups of highly
+similar genomes and choosing the best representative genome for each genome
+set.")
+ (license license:expat)))
+
(define-public gffcompare
(let ((commit "be56ef4349ea3966c12c6397f85e49e047361c41")
(revision "1"))