summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-13 08:18:36 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-13 13:52:14 -0500
commit448ebad1f6f5a6714b02daee679629a4ec8af86c (patch)
treed871cc8c62ef4da6cb1e7c18945ee54eaf4b8189 /gnu
parent3edce2c9f9b14c2cd49c54abc5abb6d651c2ed23 (diff)
downloadguix-patches-448ebad1f6f5a6714b02daee679629a4ec8af86c.tar
guix-patches-448ebad1f6f5a6714b02daee679629a4ec8af86c.tar.gz
gnu: Add Class-XSAccessor.
* gnu/packages/perl.scm (perl-class-xsaccessor): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 7292da2f14..b8ddd42280 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -439,6 +439,29 @@ Class::Load")
uses no non-core modules for any recent Perl.")
(license asl2.0)))
+(define-public perl-class-xsaccessor
+ (package
+ (name "perl-class-xsaccessor")
+ (version "1.19")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/S/SM/SMUELLER/"
+ "Class-XSAccessor-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1wm6013il899jnm0vn50a7iv9v6r4nqywbqzj0csyf8jbwwnpicr"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/Class-XSAccessor")
+ (synopsis "Generate fast XS accessors without runtime compilation")
+ (description "Class::XSAccessor implements fast read, write, and
+read/write accessors in XS. Additionally, it can provide predicates such as
+\"has_foo()\" for testing whether the attribute \"foo\" is defined in the
+object. It only works with objects that are implemented as ordinary hashes.
+Class::XSAccessor::Array implements the same interface for objects that use
+arrays for their internal representation.")
+ (license (package-license perl))))
+
(define-public perl-clone
(package
(name "perl-clone")