summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-11 16:25:04 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-12 15:55:56 -0500
commit19449405ac78d6c37bb5d061d0443f1a4487ea98 (patch)
tree047fa79468764285a929c63eae34b3f23b853bb0 /gnu
parent9acf97f2fb80fa7465fab068bcf2704557c0aafa (diff)
downloadguix-patches-19449405ac78d6c37bb5d061d0443f1a4487ea98.tar
guix-patches-19449405ac78d6c37bb5d061d0443f1a4487ea98.tar.gz
gnu: Add IO-stringy.
* gnu/packages/perl.scm (perl-io-stringy): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 39239c9daa..b02e47fa9b 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1041,6 +1041,26 @@ dependencies for CPAN distributions. These dependencies get bundled into the
inc directory within a distribution and are used by Makefile.PL or Build.PL.")
(license asl2.0)))
+(define-public perl-io-stringy
+ (package
+ (name "perl-io-stringy")
+ (version "2.110")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/D/DS/DSKOLL/"
+ "IO-stringy-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1vh4n0k22hx20rwvf6h7lp25wb7spg0089shrf92d2lkncwg8g3y"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/IO-stringy")
+ (synopsis "IO:: interface for reading/writing an array of lines")
+ (description "This toolkit primarily provides modules for performing both
+traditional and object-oriented i/o) on things *other* than normal
+filehandles; in particular, IO::Scalar, IO::ScalarArray, and IO::Lines.")
+ (license (package-license perl))))
+
(define-public perl-io-tty
(package
(name "perl-io-tty")