summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorhumanitiesNerd <catonano@gmail.com>2016-05-17 23:07:06 +0200
committerAlex Kost <alezost@gmail.com>2016-05-19 11:45:15 +0300
commit5c447e280e1a4aa6ce7c4611c8393708e08197fa (patch)
tree57ec41f7bddb54494a832e882ad5ec264b9cde74 /gnu
parent21f05134fc35edf5a15baf4fdb2e62905f3848e9 (diff)
downloadguix-patches-5c447e280e1a4aa6ce7c4611c8393708e08197fa.tar
guix-patches-5c447e280e1a4aa6ce7c4611c8393708e08197fa.tar.gz
gnu: Add emacs-smartparens.
* gnu/packages/emacs.scm (emacs-smartparens): New variable. Signed-off-by: Alex Kost <alezost@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm29
1 files changed, 28 insertions, 1 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 32ed72218b..18898e9c29 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1611,4 +1611,31 @@ number.")
It is built on top of the custom theme support in Emacs 24 or later.")
(license license:gpl3+)))
-
+(define-public emacs-smartparens
+ (package
+ (name "emacs-smartparens")
+ (version "1.7.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/Fuco1/smartparens/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1b47ppkzsj8j8a2p0bmvq05rhm2d2lsm3wlc0sg542r4zr6nji8s"))))
+ (build-system emacs-build-system)
+ (propagated-inputs `(("emacs-dash" ,emacs-dash)))
+ (home-page "https://github.com/Fuco1/smartparens")
+ (synopsis "Paredit-like insertion, wrapping and navigation with user
+defined pairs")
+ (description
+ "Smartparens is a minor mode for Emacs that deals with parens pairs
+and tries to be smart about it. It started as a unification effort to
+combine functionality of several existing packages in a single,
+compatible and extensible way to deal with parentheses, delimiters, tags
+and the like. Some of these packages include autopair, textmate,
+wrap-region, electric-pair-mode, paredit and others. With the basic
+features found in other packages it also brings many improvements as
+well as completely new features.")
+ (license license:gpl3+)))