summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorFoo Chuan Wei <chuanwei.foo@hotmail.com>2021-10-15 10:33:17 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-10-15 11:16:59 +0200
commit2bd04fd3be1ca310308055b3d9ee2264271e268f (patch)
tree55325a8315aa8a7f2310e4962c44577bc7456357 /gnu
parent9898d907e0b2cd62cbf906a5702439f47b9a3188 (diff)
downloadguix-patches-2bd04fd3be1ca310308055b3d9ee2264271e268f.tar
guix-patches-2bd04fd3be1ca310308055b3d9ee2264271e268f.tar.gz
gnu: Add cl-montezuma.
* gnu/packages/lisp-xyz.scm (cl-montezuma, ecl-montezuma, sbcl-montezuma): New variables. Co-authored-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp-xyz.scm61
1 files changed, 61 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 65f3e869dd..3a084b32b7 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -19140,3 +19140,64 @@ diffs, \"context\" format diffs, and \"vdelta\" format binary diffs.")
(define-public ecl-diff
(sbcl-package->ecl-package sbcl-diff))
+
+(define-public sbcl-montezuma
+ (let ((commit "ee2129eece7065760de4ebbaeffaadcb27644738")
+ (revision "1"))
+ (package
+ (name "sbcl-montezuma")
+ (version (git-version "0.1.3" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sharplispers/montezuma")
+ (commit commit)))
+ (file-name (git-file-name "cl-montezuma" version))
+ (sha256
+ (base32 "0svmvsbsirydk3c1spzfvj8qmkzcs9i69anpfvk1843i62wb7x2c"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; The _darcs directory contains a second copy of
+ ;; montezuma-indexfiles.asd. Remove the directory to
+ ;; prevent build failure caused by .asd files that have
+ ;; the same filename.
+ (add-after 'unpack 'remove-darcs-directory
+ (lambda _
+ (delete-file-recursively
+ "contrib/montezuma-indexfiles/_darcs")))
+ ;; Tests fail with: :FORCE and :FORCE-NOT arguments not
+ ;; allowed in a nested call to ASDF/OPERATE:OPERATE unless
+ ;; identically to toplevel.
+ (add-after 'unpack 'fix-tests
+ (lambda _
+ (substitute* "montezuma.asd"
+ ((":force t") "")))))))
+ (inputs
+ `(("babel" ,sbcl-babel)
+ ("cl-fad" ,sbcl-cl-fad)
+ ("cl-ppcre" ,sbcl-cl-ppcre)))
+ (native-inputs
+ `(("trivial-timeout" ,sbcl-trivial-timeout)))
+ (home-page "https://github.com/sharplispers/montezuma")
+ (synopsis "Full-text indexing and search for Common Lisp")
+ (description
+ "Montezuma is a text search engine library for Lisp based on the Ferret
+library for Ruby, which is itself based on the Lucene library for Java.")
+ (license (list license:expat ; montezuma
+ license:gpl3+))))) ; contrib/montezuma-indexfiles
+
+(define-public cl-montezuma
+ (sbcl-package->cl-source-package sbcl-montezuma))
+
+(define-public ecl-montezuma
+ (let ((pkg (sbcl-package->ecl-package sbcl-montezuma)))
+ (package
+ (inherit pkg)
+ (arguments
+ (substitute-keyword-arguments (package-arguments pkg)
+ ;; Tests fail with "Pathname without a physical namestring" error
+ ;; on ECL.
+ ((#:tests? _ #f) #f))))))