summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-06-16 23:32:36 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-06-17 09:50:44 -0400
commitcb4b60bceea1110f357af8e1f20cd32629774c84 (patch)
tree95ff9a5bb5da6515f4a0358a7743361a8a6a4c7d /gnu
parentb8744955f538f624901726d79c66108385d66a26 (diff)
downloadguix-patches-cb4b60bceea1110f357af8e1f20cd32629774c84.tar
guix-patches-cb4b60bceea1110f357af8e1f20cd32629774c84.tar.gz
gnu: emacs-elpy: Disable two tests that fail when building with Emacs 27.
* gnu/packages/emacs-xyz.scm (emacs-elpy)[phases]{disable-problematic-tests}: New phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0cf769779e..c92b5723a1 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -7399,6 +7399,17 @@ indentation guides in Emacs:
`(#:include (cons* "^elpy/[^/]+\\.py$" "^snippets\\/" %default-include)
#:phases
(modify-phases %standard-phases
+ ;; The following tests fail when building with Emacs 27 (see:
+ ;; https://github.com/jorgenschaefer/elpy/issues/1812).
+ (add-after 'unpack 'disable-problematic-tests
+ (lambda _
+ (substitute* "test/elpy-company-backend-test.el"
+ (("elpy-company-backend-should-add-shell-candidates.*" all)
+ (string-append all " (skip-unless nil)\n")))
+ (substitute* "test/elpy-folding-fold-comments-test.el"
+ (("elpy-fold-at-point-should-fold-and-unfold-comments.*" all)
+ (string-append all " (skip-unless nil)\n")))
+ #t))
;; The default environment of the RPC uses Virtualenv to install
;; Python dependencies from PyPI. We don't want/need this in Guix.
(add-before 'check 'do-not-use-virtualenv