summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-07-13 19:04:27 -0400
committerMark H Weaver <mhw@netris.org>2015-07-13 19:04:27 -0400
commit412a242258def6668a933efc56dd60bbd286d389 (patch)
treef56f9336127e411542f91fe45500f2706e96a1d6 /gnu
parent92e79092ebad48d0afe26eeb2fee9ff46fcb6732 (diff)
downloadguix-patches-412a242258def6668a933efc56dd60bbd286d389.tar
guix-patches-412a242258def6668a933efc56dd60bbd286d389.tar.gz
gnu: liba52: Remove --build from configure flags.
This is a followup to commit 3c7d023d6458669c6bfa23bc85e098c91f699892, "build-system/gnu: Pass --build=<triplet> to configure by default" * gnu/packages/video.scm (liba52)[arguments]: Remove --build from configure flags.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm9
1 files changed, 1 insertions, 8 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index d0983808c6..99cdd1ae09 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -139,14 +139,7 @@ old-fashioned output methods with powerful ascii-art renderer.")
`(("autoconf" ,autoconf)
("automake" ,automake)
("libtool" ,libtool)))
- (arguments `(#:configure-flags
- '("--enable-shared"
- ;; FIXME: liba52-0.7.4's config.guess fails on mips64el.
- ,@(if (%current-target-system)
- '()
- (let ((triplet
- (nix-system->gnu-triplet (%current-system))))
- (list (string-append "--build=" triplet)))))
+ (arguments `(#:configure-flags '("--enable-shared")
#:phases
(modify-phases %standard-phases
;; XXX We need to run ./bootstrap because of the build