summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-07-29 18:29:58 -0400
committerMark H Weaver <mhw@netris.org>2016-07-29 18:29:58 -0400
commit359aba76b655813895e7ed9290110e3750914d8b (patch)
treea9f3493e76277cfc906e44c0fb1df07300f73260 /gnu
parent0bab3af0786ffd4caec05a29d7281ac5e5c18b6b (diff)
parent9bdf56dc1349d1759fc670ff8715de25de0f0a9c (diff)
downloadguix-patches-359aba76b655813895e7ed9290110e3750914d8b.tar
guix-patches-359aba76b655813895e7ed9290110e3750914d8b.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/databases.scm6
-rw-r--r--gnu/packages/gd.scm3
-rw-r--r--gnu/packages/networking.scm4
-rw-r--r--gnu/packages/patches/gd-fix-gd2-read-test.patch14
-rw-r--r--gnu/packages/protobuf.scm7
6 files changed, 26 insertions, 9 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 84e1d77f66..1417a3c7d5 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -515,6 +515,7 @@ dist_patch_DATA = \
%D%/packages/patches/gcc-cross-environment-variables.patch \
%D%/packages/patches/gcc-libvtv-runpath.patch \
%D%/packages/patches/gcc-5.0-libvtv-runpath.patch \
+ %D%/packages/patches/gd-fix-gd2-read-test.patch \
%D%/packages/patches/gd-fix-tests-on-i686.patch \
%D%/packages/patches/gegl-CVE-2012-4433.patch \
%D%/packages/patches/geoclue-config.patch \
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 36cfad3102..895045d952 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -772,15 +772,15 @@ columns, primary keys, unique constraints and relationships.")
(define-public perl-dbd-mysql
(package
(name "perl-dbd-mysql")
- (version "4.033")
+ (version "4.035")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/C/CA/CAPTTOFU/"
+ (uri (string-append "mirror://cpan/authors/id/M/MI/MICHIELB/"
"DBD-mysql-" version ".tar.gz"))
(sha256
(base32
- "0769xakykps0cx368g4vaips4w3bjk383rianiavq7sq6g6bp66c"))))
+ "0dqrnrk8yjl06xl8hld5wyalk77z0h9j5h1gdk4z9g0nx9js7v5p"))))
(build-system perl-build-system)
;; Tests require running MySQL server
(arguments `(#:tests? #f))
diff --git a/gnu/packages/gd.scm b/gnu/packages/gd.scm
index 153e1c7f8b..b1bbc22cd7 100644
--- a/gnu/packages/gd.scm
+++ b/gnu/packages/gd.scm
@@ -50,7 +50,8 @@
(sha256
(base32
"0g3xz8jpz1pl2zzmssglrpa9nxiaa7rmcmvgpbrjz8k9cyynqsvl"))
- (patches (search-patches "gd-fix-tests-on-i686.patch"))))
+ (patches (search-patches "gd-fix-gd2-read-test.patch"
+ "gd-fix-tests-on-i686.patch"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 8b76b0738f..5135fb07f7 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -331,7 +331,7 @@ and up to 1 Mbit/s downstream.")
(define-public wireshark
(package
(name "wireshark")
- (version "2.0.4")
+ (version "2.0.5")
(synopsis "Network traffic analyzer")
(source
(origin
@@ -340,7 +340,7 @@ and up to 1 Mbit/s downstream.")
version ".tar.bz2"))
(sha256
(base32
- "19g11m8m8qd7dkcvcb27lyppklg608d9ap7wr3mr88clm4nwiacy"))))
+ "02xi3fz8blcz9cf75rs11g7bijk06wm45vpgnksp72c2609j9q0c"))))
(build-system glib-or-gtk-build-system)
(inputs `(("bison" ,bison)
("c-ares" ,c-ares)
diff --git a/gnu/packages/patches/gd-fix-gd2-read-test.patch b/gnu/packages/patches/gd-fix-gd2-read-test.patch
new file mode 100644
index 0000000000..65f39e4426
--- /dev/null
+++ b/gnu/packages/patches/gd-fix-gd2-read-test.patch
@@ -0,0 +1,14 @@
+Fix a 'maybe-uninitialized' warning (turned error)
+which occurs on non-Intel platforms.
+
+--- libgd-2.2.3/tests/gd2/gd2_read.c 2016-07-21 01:21:16.000000000 -0400
++++ libgd-2.2.3/tests/gd2/gd2_read.c 2016-07-29 15:52:03.806405312 -0400
+@@ -5,7 +5,7 @@
+
+ int main(int argc, char *argv[])
+ {
+- int error, i = 0;
++ int error = 0, i = 0;
+ gdImagePtr im, exp;
+ FILE *fp;
+ char *path[] = {
diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
index 86c418bb05..e1a3d8a6f1 100644
--- a/gnu/packages/protobuf.scm
+++ b/gnu/packages/protobuf.scm
@@ -32,14 +32,15 @@
(define-public protobuf
(package
(name "protobuf")
- (version "2.5.0")
+ (version "2.6.1")
(source (origin
(method url-fetch)
- (uri (string-append "http://protobuf.googlecode.com/files/protobuf-"
+ (uri (string-append "https://github.com/google/protobuf/releases/"
+ "download/v" version "/protobuf-"
version ".tar.bz2"))
(sha256
(base32
- "0xxn9gxhvsgzz2sgmihzf6pf75clr05mqj6218camwrwajpcbgqk"))))
+ "040rcs9fpv4bslhiy43v7dcrzakz4vwwpyqg4jp8bn24sl95ci7f"))))
(build-system gnu-build-system)
(inputs `(("zlib" ,zlib)))
(home-page "http://code.google.com/p/protobuf/")