summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-18 15:25:38 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-18 15:29:08 +0100
commit43b66e3f7c7628804faf0f336c903458d319f412 (patch)
tree94dba7ce789fbc57fdfcbabf49c8ef608ff392c9 /gnu
parent4a18112dfb738c325f9ef0145e9480df642ec9b8 (diff)
downloadguix-patches-43b66e3f7c7628804faf0f336c903458d319f412.tar
guix-patches-43b66e3f7c7628804faf0f336c903458d319f412.tar.gz
gnu: Add r-biocset.
* gnu/packages/bioconductor.scm (r-biocset): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index c5ad29297c..8bd6bfe7af 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -7318,3 +7318,36 @@ that metadata from R. The goal is to expose metadata for data mining and
value-added functionality such as package searching, text mining, and
analytics on packages.")
(license license:expat)))
+
+(define-public r-biocset
+ (package
+ (name "r-biocset")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "BiocSet" version))
+ (sha256
+ (base32
+ "1xcksnvjflrdarn8xqmgf0n6wbsjkq9jazqwp35i52vqcq4ic1j9"))))
+ (properties `((upstream-name . "BiocSet")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-annotationdbi" ,r-annotationdbi)
+ ("r-dplyr" ,r-dplyr)
+ ("r-keggrest" ,r-keggrest)
+ ("r-plyr" ,r-plyr)
+ ("r-rlang" ,r-rlang)
+ ("r-rtracklayer" ,r-rtracklayer)
+ ("r-tibble" ,r-tibble)))
+ (home-page
+ "https://bioconductor.org/packages/BiocSet")
+ (synopsis
+ "Representing Different Biological Sets")
+ (description
+ "BiocSet displays different biological sets in a triple tibble format.
+These three tibbles are @code{element}, @code{set}, and @code{elementset}.
+The user has the abilty to activate one of these three tibbles to perform
+common functions from the @code{dplyr} package. Mapping functionality and
+accessing web references for elements/sets are also available in BiocSet.")
+ (license license:artistic2.0)))