summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2020-08-30 09:50:25 +0200
committerMathieu Othacehe <othacehe@gnu.org>2020-09-01 21:25:52 +0200
commita73ccefe315cd16e9d0b31a00bbd61e6cc3042f5 (patch)
treed7a25d6e8ff9cf585b675289e343e66fc247c511 /gnu
parent08a8872f7ffc3bf304e16423d23aef01c77eabcd (diff)
downloadguix-patches-a73ccefe315cd16e9d0b31a00bbd61e6cc3042f5.tar
guix-patches-a73ccefe315cd16e9d0b31a00bbd61e6cc3042f5.tar.gz
gnu: emacs-elisp-refs: Disable test failing on Emacs 27.1.
* gnu/packages/emacs-xyz.scm (emacs-elisp-refs)[arguments]: Add phase to disable failing test "elisp-refs-next-match" on emacs27. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0066d6073e..c3d9fcabea 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -14827,7 +14827,17 @@ continue.")
("emacs-undercover" ,emacs-undercover)))
(arguments
`(#:tests? #t
- #:test-command '("ert-runner")))
+ #:test-command '("ert-runner")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'disable-refs-next-match-test
+ ;; Hack to disable the failing test for emacs27
+ ;; https://github.com/Wilfred/elisp-refs/issues/29
+ (lambda _
+ (substitute* "test/unit-test.el"
+ (("ert-deftest elisp-refs-next-match")
+ "defun elisp-refs-next-match"))
+ #t)))))
(home-page "https://github.com/Wilfred/elisp-refs")
(synopsis "Find callers of elisp functions or macros")
(description "Find references to functions, macros or variables. Unlike a