summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-07-18 13:39:03 -0400
committerMark H Weaver <mhw@netris.org>2018-07-18 13:55:47 -0400
commit46978ff64f55ae09b578b73c52c789eabb3fe5c1 (patch)
tree99b57abb586792d8abc650eca7279d369bcfde6c /gnu
parent16c09025878b9148fc091b828d1f016d0e1f46bf (diff)
downloadguix-patches-46978ff64f55ae09b578b73c52c789eabb3fe5c1.tar
guix-patches-46978ff64f55ae09b578b73c52c789eabb3fe5c1.tar.gz
gnu: linux-libre: Update to 4.17.7.
* gnu/packages/linux.scm (%linux-libre-version): Update to 4.17.7. (%linux-libre-hash): Update hash. (linux-libre)[source]: Add upstream patch to fix i686.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm17
1 files changed, 14 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index c70d4c46d5..dc6c6b1239 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -404,14 +404,25 @@ It has been modified to remove all non-free binary blobs.")
;; supports qemu "virt" machine and possibly a large number of ARM boards.
;; See : https://wiki.debian.org/DebianKernel/ARMMP.
-(define %linux-libre-version "4.17.6")
-(define %linux-libre-hash "0d48r5jpj71ikdalz5z756snwq54cpnwnba8bbhg8r2ri3770wcm")
+(define %linux-libre-version "4.17.7")
+(define %linux-libre-hash "1815h0kf6c07zp9782v9n9a21x8wzdr4ws190nqp7z2xyip6xfjj")
(define-public linux-libre
(make-linux-libre %linux-libre-version
%linux-libre-hash
%linux-compatible-systems
- #:configuration-file kernel-config))
+ #:configuration-file kernel-config
+ #:patches
+ (list
+ (origin
+ (method url-fetch)
+ (uri "https://git.kernel.org/pub/scm/linux/kernel/git/\
+stable/linux.git/patch/?id=27d8b7daf73827e8263ab0b740da6ebdda9f9d56")
+ (file-name "linux-libre-4.17.7-fix-i686.patch")
+ (sha256
+ (base32
+ "0xbv04vwhyk3wvia13ca6kbysjqwsywcj6501i2wpddawm4q23sc")))
+ %boot-logo-patch)))
(define %linux-libre-4.14-version "4.14.56")
(define %linux-libre-4.14-hash "15a4gsi1nsjab16qwfizc0bdn0h27w54qy2a50847i0ln4akdrzl")