summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-09-17 19:00:45 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-09-17 19:40:10 +0300
commit7009d20ad3590dd163ffb075ae051ae1ac932cb6 (patch)
treee7694f895c8a586ec9067c4f7c06786f5a37dc8c /gnu
parent03e22b2eee16a5958a112db48b2e94584ed37bf2 (diff)
downloadguix-patches-7009d20ad3590dd163ffb075ae051ae1ac932cb6.tar
guix-patches-7009d20ad3590dd163ffb075ae051ae1ac932cb6.tar.gz
gnu: Add rust-futures-sink-preview.
* gnu/packages/crates-io.scm (rust-futures-sink-preview): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 1b7989e072..e2a404b54d 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -1124,6 +1124,30 @@ the computation on the threads themselves.")
(license (list license:asl2.0
license:expat))))
+(define-public rust-futures-sink-preview
+ (package
+ (name "rust-futures-sink-preview")
+ (version "0.3.0-alpha.17")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "futures-sink-preview" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1r4d0gy73hdxkh5g1lrhl1kjnwp6mywjgcj70v0z78b921da42a3"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-futures-core-preview" ,rust-futures-core-preview))))
+ (home-page "https://rust-lang-nursery.github.io/futures-rs/")
+ (synopsis "Asynchronous `Sink` trait for the futures-rs library")
+ (description
+ "This package provides the asynchronous @code{Sink} trait for the
+futures-rs library.")
+ (license (list license:asl2.0
+ license:expat))))
+
(define-public rust-gcc
(package
(inherit rust-cc)