summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-08-11 12:18:37 +0200
committerLudovic Courtès <ludo@gnu.org>2021-08-30 14:40:18 +0200
commitb12d856da9a9f088f15a29da87cf4304b5379e5d (patch)
tree31af35894779bf51098737b421de9f8a877c32d9 /gnu
parent0508622848f65795d71c4dc860e0151291bff044 (diff)
downloadguix-patches-b12d856da9a9f088f15a29da87cf4304b5379e5d.tar
guix-patches-b12d856da9a9f088f15a29da87cf4304b5379e5d.tar.gz
gnu: Add ocaml-odoc-parser.
* gnu/packages/ocaml.scm (ocaml-odoc-parser): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index c1cdc8f3f3..ecaf024b40 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6613,6 +6613,34 @@ advantage over ocamldoc is an accurate cross-referencer, which handles the
complexity of the OCaml module system.")
(license license:isc)))
+(define-public ocaml-odoc-parser
+ (package
+ (name "ocaml-odoc-parser")
+ (version "0.9.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ocaml-doc/odoc-parser")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1jlc6dp3v90r1ra7r0jfw0xs8rylwdz9gymw4rd53h0p17cw1wnj"))))
+ (build-system dune-build-system)
+ (propagated-inputs
+ `(("ocaml-astring" ,ocaml-astring)
+ ("ocaml-result" ,ocaml-result)))
+ (native-inputs
+ `(("ocaml-ppx-expect" ,ocaml-ppx-expect)))
+ (home-page "https://github.com/ocaml-doc/odoc-parser")
+ (synopsis "Parser for ocaml documentation comments")
+ (description
+ "This package provides a library for parsing the contents of OCaml
+documentation comments, formatted using Odoc syntax, an extension of the
+language understood by ocamldoc.")
+ (license license:isc)))
+
;; version 1.5.2 requires ocaml-markdown 1.0.0 which does not compile
;; with old version of dune used in package-with-ocaml4.07
(define-public ocaml4.07-odoc