summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-25 15:36:58 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-14 14:06:29 +0100
commitb004fb6a8a28d220ad61128bc4e6040bb29df7ea (patch)
tree02ebec3c0587dc5d7c4326a8cb8680dd79504ef3 /gnu
parent763624f56616eae6c974e8d6c1acc257020154dd (diff)
downloadguix-patches-b004fb6a8a28d220ad61128bc4e6040bb29df7ea.tar
guix-patches-b004fb6a8a28d220ad61128bc4e6040bb29df7ea.tar.gz
gnu: Add ruby-saikuro-treemap.
* gnu/packages/ruby.scm (ruby-saikuro-treemap): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index eb6abbf3d2..06eca79019 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -572,6 +572,32 @@ format.")
(home-page "https://github.com/nicksieger/ci_reporter")
(license license:expat)))
+(define-public ruby-saikuro-treemap
+ (package
+ (name "ruby-saikuro-treemap")
+ (version "0.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "saikuro_treemap" version))
+ (sha256
+ (base32
+ "0w70nmh43mwfbpq20iindl61siqqr8acmf7p3m7n5ipd61c24950"))))
+ (build-system ruby-build-system)
+ ;; Some of the tests fail because the generated JSON has keys in a
+ ;; different order. This is a problem with the test suite rather than any
+ ;; of the involved libraries.
+ (arguments `(#:tests? #f))
+ (propagated-inputs
+ `(("ruby-json-pure" ,ruby-json-pure)
+ ("ruby-atoulme-saikuro" ,ruby-atoulme-saikuro)))
+ (synopsis "Generate complexity treemap based on saikuro analysis")
+ (description
+ "This gem generates a treemap showing the complexity of Ruby code on
+which it is run. It uses Saikuro under the covers to analyze Ruby code
+complexity.")
+ (home-page "http://github.com/ThoughtWorksStudios/saikuro_treemap")
+ (license license:expat)))
+
(define-public ruby-orderedhash
(package
(name "ruby-orderedhash")