summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-25 15:43:10 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-14 14:06:29 +0100
commit5799bc2b1f9bfbbf3fb2acc3a3adab9acfcdf66b (patch)
tree82a90864d16a511e7a6a0ac9ef972868bc0bd13a /gnu
parent051deeb79d1737477e298a322de35ddb962911f4 (diff)
downloadguix-patches-5799bc2b1f9bfbbf3fb2acc3a3adab9acfcdf66b.tar
guix-patches-5799bc2b1f9bfbbf3fb2acc3a3adab9acfcdf66b.tar.gz
gnu: Add ruby-netrc.
* gnu/packages/ruby.scm (ruby-netrc): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 5c8d684cde..2454148bc2 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -2354,6 +2354,36 @@ other things and it comes with a command line interface.")
(home-page "http://github.com/deivid-rodriguez/byebug")
(license license:bsd-2)))
+(define-public ruby-netrc
+ (package
+ (name "ruby-netrc")
+ (version "0.11.0")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "netrc" version))
+ (sha256
+ (base32
+ "0gzfmcywp1da8nzfqsql2zqi648mfnx6qwkig3cv36n9m0yy676y"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ ;; There is no Rakefile and minitest can only run one file at once,
+ ;; so we have to iterate over all test files.
+ (lambda _
+ (and (map (lambda (file)
+ (zero? (system* "ruby" "-Itest" file)))
+ (find-files "./test" "test_.*\\.rb"))))))))
+ (native-inputs
+ `(("ruby-minitest" ,ruby-minitest)))
+ (synopsis "Library to read and update netrc files")
+ (description
+ "This library can read and update netrc files, preserving formatting
+including comments and whitespace.")
+ (home-page "https://github.com/geemus/netrc")
+ (license license:expat)))
+
(define-public ruby-rack
(package
(name "ruby-rack")