summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-09-14 04:18:03 +0530
committerKei Kebreau <kkebreau@posteo.net>2017-09-22 08:04:33 -0400
commit823e12184883e6f4a7a347a4eba46327f99a5b84 (patch)
tree38f4e728a479d65eec4ca0d8622bb066e011cb06 /gnu
parentc17b079043ba6dc20b4aa690a7d30eb8d9680f63 (diff)
downloadguix-patches-823e12184883e6f4a7a347a4eba46327f99a5b84.tar
guix-patches-823e12184883e6f4a7a347a4eba46327f99a5b84.tar.gz
gnu: Add openttd-openmsx.
* gnu/packages/games.scm (openttd-openmsx): New variable. Signed-off-by: Kei Kebreau <kkebreau@posteo.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index ed386fc843..891c17ab15 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2563,6 +2563,44 @@ it possible to play OpenTTD without requiring the proprietary sound files from
the original Transport Tycoon Deluxe.")
(license license:cc-sampling-plus-1.0)))
+(define openttd-openmsx
+ (package
+ (name "openttd-openmsx")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://binaries.openttd.org/extra/openmsx/"
+ version "/openmsx-" version "-source.tar.gz"))
+ (sha256
+ (base32
+ "0nskq97a6fsv1v6d62zf3yb8whzhqnlh3lap3va3nzvj7csjgf7c"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("python" ,python2-minimal)))
+ (arguments
+ `(#:make-flags
+ (list (string-append "INSTALL_DIR=" %output
+ "/share/games/openttd/baseset"))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'install 'post-install
+ ;; Rename openmsx-version to openmsx
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((install-directory (string-append (assoc-ref outputs "out")
+ "/share/games/openttd/baseset")))
+ (rename-file (string-append install-directory "/openmsx-" ,version)
+ (string-append install-directory "/openmsx"))
+ #t))))))
+ (home-page "http://dev.openttdcoop.org/projects/openmsx")
+ (synopsis "Music set for OpenTTD")
+ (description "OpenMSX is a music set for OpenTTD which makes it possible
+to play OpenTTD without requiring the proprietary music from the original
+Transport Tycoon Deluxe.")
+ (license license:gpl2)))
+
(define-public openttd
(package
(inherit openttd-engine)