summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2021-11-18 14:21:45 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-18 14:46:49 +0100
commit9502c56bfb19e20be81e079446bfd1da3f9de97b (patch)
treeb4899abb67d3d9fbdd406ce66910b628f2426ae0 /gnu
parentee98739c832a39da603cb430771e0b6131c9f227 (diff)
downloadguix-patches-9502c56bfb19e20be81e079446bfd1da3f9de97b.tar
guix-patches-9502c56bfb19e20be81e079446bfd1da3f9de97b.tar.gz
gnu: gnome-builder: Upgrade to 41.2.
* gnu/packages/gnome.scm: Import modules llvm and markup for gnome-builder. (gnome-builder): Upgrade to 41.2. [arguments]: Add #:glib-or-gtk? #t to compile the schemas. [configure-flags]: Enable more plugins. [phase patch-meson]: Pretend we’re building with webkit2gtk-4.1. [inputs]: Add cmark (markup support), clang and llvm, devhelp, glade, libportal and libsoup 2. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm27
1 files changed, 17 insertions, 10 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 5f8de271cc..cb9f7afb78 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -147,9 +147,11 @@
#:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
#:use-module (gnu packages lirc)
+ #:use-module (gnu packages llvm)
#:use-module (gnu packages lua)
#:use-module (gnu packages mail)
#:use-module (gnu packages man)
+ #:use-module (gnu packages markup)
#:use-module (gnu packages mp3)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages music)
@@ -12311,25 +12313,22 @@ libraries. Applications do not need to be recompiled--or even restarted.")
(define-public gnome-builder
(package
(name "gnome-builder")
- (version "3.36.1")
+ (version "41.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
- (version-major+minor version) "/"
+ (version-major version) "/"
name "-" version ".tar.xz"))
(sha256
(base32
- "17pvmd5jypar8dkr6w56hvf7jnq4l1wih2wwgkrv7sblr7rkkar2"))))
+ "04p031i999dccbnlbysmr6f93x7dji7b559j6yhdsqbqgxb7ncan"))))
(build-system meson-build-system)
(arguments
- `(#:configure-flags (list "-Dnetwork_tests=false"
+ `(#:glib-or-gtk? #t ; To wrap binaries and compile schemas
+ #:configure-flags (list "-Dnetwork_tests=false"
;; TODO: Enable all plugins...
- "-Dplugin_clang=false"
+ ;; Flatpak plugin wants libsoup 2
"-Dplugin_flatpak=false"
- "-Dplugin_glade=false"
- ;; XXX: This one has been shown not to work in
- ;; <https://issues.guix.gnu.org/45272>
- "-Dplugin_jedi=false"
;; ... except this one.
"-Dplugin_update_manager=false")
#:phases
@@ -12343,6 +12342,8 @@ libraries. Applications do not need to be recompiled--or even restarted.")
(("/usr/lib")
(string-append (assoc-ref inputs "python-pygobject")
"/lib")))
+ (substitute* "meson.build"
+ (("webkit2gtk-4.0") "webkit2gtk-4.1"))
#t))
(add-after 'configure 'fix-ninja
(lambda _
@@ -12357,7 +12358,10 @@ libraries. Applications do not need to be recompiled--or even restarted.")
(setenv "DISPLAY" ":1")
#t)))))
(inputs
- `(("devhelp" ,devhelp)
+ `(("cmark" ,cmark)
+ ("clang" ,clang)
+ ("devhelp" ,devhelp)
+ ("glade" ,glade3)
("gspell" ,gspell)
("gtk+" ,gtk+)
("json-glib" ,json-glib)
@@ -12365,6 +12369,9 @@ libraries. Applications do not need to be recompiled--or even restarted.")
("libdazzle" ,libdazzle)
("libgit2-glib" ,libgit2-glib)
("libpeas" ,libpeas)
+ ("libportal" ,libportal)
+ ("libsoup" ,libsoup-minimal-2)
+ ("llvm" ,llvm)
("python-pygobject" ,python-pygobject)
("sysprof" ,sysprof)
("template-glib" ,template-glib)