summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-10-05 13:51:04 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-10-08 09:13:53 +0200
commit7eb9fe4e538ce8cdac28abb0e5433b1b797b5030 (patch)
treea27e96ad2b016aac4a16356f73c88593366746db /gnu
parented044023d7ed8cfe113f4d6e1a6af17a09f49795 (diff)
downloadguix-patches-7eb9fe4e538ce8cdac28abb0e5433b1b797b5030.tar
guix-patches-7eb9fe4e538ce8cdac28abb0e5433b1b797b5030.tar.gz
gnu: ngless: Fix build.
Apply upstream patch to restore compatibility with current Stackage. * gnu/packages/patches/ngless-unliftio.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/bioinformatics.scm (ngless): Use it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/bioinformatics.scm3
-rw-r--r--gnu/packages/patches/ngless-unliftio.patch66
3 files changed, 69 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 9c83d7e6bd..43bb7208ba 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1513,6 +1513,7 @@ dist_patch_DATA = \
%D%/packages/patches/nettle-3.5-CVE-2021-3580-pt2.patch \
%D%/packages/patches/nfs4-acl-tools-0.3.7-fixpaths.patch \
%D%/packages/patches/ngircd-handle-zombies.patch \
+ %D%/packages/patches/ngless-unliftio.patch \
%D%/packages/patches/network-manager-plugin-path.patch \
%D%/packages/patches/nginx-socket-cloexec.patch \
%D%/packages/patches/nnpack-system-libraries.patch \
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index aa4c1ee8f4..932073ef5a 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -12467,7 +12467,8 @@ datasets.")
(file-name (git-file-name name version))
(sha256
(base32
- "0pb9f6b0yk9p4cdwiym8r190q1bcdiwvc7i2s6rw54qgi8r3g6pj"))))
+ "0pb9f6b0yk9p4cdwiym8r190q1bcdiwvc7i2s6rw54qgi8r3g6pj"))
+ (patches (search-patches "ngless-unliftio.patch"))))
(build-system haskell-build-system)
(arguments
`(#:haddock? #f ; The haddock phase fails with: NGLess/CmdArgs.hs:20:1:
diff --git a/gnu/packages/patches/ngless-unliftio.patch b/gnu/packages/patches/ngless-unliftio.patch
new file mode 100644
index 0000000000..87f5e79fcf
--- /dev/null
+++ b/gnu/packages/patches/ngless-unliftio.patch
@@ -0,0 +1,66 @@
+From 919565adc1216b9d3108b3043e8d307292b37393 Mon Sep 17 00:00:00 2001
+From: Luis Pedro Coelho <luis@luispedro.org>
+Date: Fri, 7 May 2021 11:42:56 +0800
+Subject: [PATCH] BLD Update to LTS-17.10
+
+- Updates the GHC version
+- Requires `extra-deps` for `diagrams` package
+- Simplifies code for NGLessIO monad as UnliftIO can now be auto-derived
+---
+ NGLess/NGLess/NGError.hs | 8 ++------
+ stack.yaml | 11 ++++++++---
+ 2 files changed, 10 insertions(+), 9 deletions(-)
+
+diff --git a/NGLess/NGLess/NGError.hs b/NGLess/NGLess/NGError.hs
+index a22e557f..c7eddf5b 100644
+--- a/NGLess/NGLess/NGError.hs
++++ b/NGLess/NGLess/NGError.hs
+@@ -50,7 +50,8 @@ type NGLess = Either NGError
+
+ newtype NGLessIO a = NGLessIO { unwrapNGLessIO :: ResourceT IO a }
+ deriving (Functor, Applicative, Monad, MonadIO,
+- MonadResource, MonadThrow, MonadCatch, MonadMask)
++ MonadResource, MonadThrow, MonadCatch, MonadMask,
++ MonadUnliftIO)
+
+
+ instance MonadError NGError NGLessIO where
+@@ -62,11 +63,6 @@ instance PrimMonad NGLessIO where
+ primitive act = NGLessIO (primitive act)
+ {-# INLINE primitive #-}
+
+-instance MonadUnliftIO NGLessIO where
+- askUnliftIO = NGLessIO $ do
+- u <- askUnliftIO
+- return $ UnliftIO (\(NGLessIO act) -> unliftIO u act)
+-
+ instance MonadFail NGLessIO where
+ fail err = throwShouldNotOccur err
+
+diff --git a/stack.yaml b/stack.yaml
+index 051d973d..11b65887 100644
+--- a/stack.yaml
++++ b/stack.yaml
+@@ -1,14 +1,19 @@
+ # For more information, see: https://github.com/commercialhaskell/stack/blob/release/doc/yaml_configuration.md
+
+-resolver: lts-14.20
++resolver: lts-17.10
+ compiler-check: newer-minor
+
+ # Packages to be pulled from upstream that are not in the resolver (e.g., acme-missiles-0.3)
+ extra-deps:
+ - git: "https://github.com/ngless-toolkit/interval-to-int"
+ commit: "78289f6b48d41f7cc48169520ec9b77b050a0029"
+-
+-
++ - diagrams-core-1.4.2@sha256:47de45658e8a805b7cb7f535e7b093daf7e861604fa3c70e25bd4ef481bf1571,2997
++ - diagrams-lib-1.4.3@sha256:04f77778d4b550d3c8e54440800685f88467bef91075e82e009a8a6f45c51033,8232
++ - diagrams-svg-1.4.3@sha256:36708b0b4cf35507ccf689f1a25f6f81b8f41c2c4c2900793de820f66d4e241c,3181
++ - active-0.2.0.14@sha256:e618aba4a7881eb85dc1585e0a01230af6b4fbab6693931e4a5d0d3a5b184406,1823
++ - dual-tree-0.2.2.1@sha256:9ff31e461d873ae74ba51d93b454c0c4094726d7cb78a0c454394c965e83539d,2830
++ - monoid-extras-0.5.1@sha256:438dbfd7b4dce47d8f0ca577f56caf94bd1e21391afa545cad09fe7cf2e5793d,2333
++ - svg-builder-0.1.1@sha256:22de54d326a6b6912e461e1302edb9108b02aac0b6a6368fcdc3c4a224d487fd,1440
+ allow-newer: true
+
+ # Override default flag values for local packages and extra-deps