summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-07-20 09:39:54 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-07-25 02:00:22 -0400
commite0fc0913195a9e79dafc6075764132126fbd7d9c (patch)
tree4be8ecedefb7213016ffd9ff2a82a780631d3789 /gnu
parent17a8656bc75fa6e7b83bfd3d7617af8c0e8bd21d (diff)
downloadguix-patches-e0fc0913195a9e79dafc6075764132126fbd7d9c.tar
guix-patches-e0fc0913195a9e79dafc6075764132126fbd7d9c.tar.gz
gnu: weston: Fix package inputs.
The newly added inputs are referenced by the package but was missing in the package definition. Some of these inputs might have been used by the package indirectly via propagation from other inputs. The moved inputs are referenced in pkg-config files. * gnu/packages/freedesktop.scm (weston)[inputs]: Add glib, libdrm, libpng, libx11 and libxcb. Move libxkbcommon and wayland to ... [propagated-inputs]: ... here. Add pixman.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/freedesktop.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index baebb0abd4..4cea482927 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1057,24 +1057,31 @@ applications, X servers (rootless or fullscreen) or other display servers.")
("colord" ,colord)
("dbus" ,dbus)
("elogind" ,elogind)
+ ("glib" ,glib)
("lcms" ,lcms)
+ ("libdrm" ,libdrm)
("libevdev" ,libevdev)
("libinput" ,libinput-minimal)
("libjpeg" ,libjpeg-turbo)
+ ("libpng" ,libpng)
("libunwind" ,libunwind)
("libva" ,libva)
("libwebp" ,libwebp)
+ ("libx11" ,libx11)
+ ("libxcb" ,libxcb)
("libxcursor" ,libxcursor)
- ("libxkbcommon" ,libxkbcommon)
("libxml2" ,libxml2)
("mesa" ,mesa)
("mtdev" ,mtdev)
("linux-pam" ,linux-pam)
("pango" ,pango)
("pipewire" ,pipewire)
- ("wayland" ,wayland)
("wayland-protocols" ,wayland-protocols)
("xorg-server-xwayland" ,xorg-server-xwayland)))
+ (propagated-inputs
+ `(("libxkbcommon" ,libxkbcommon)
+ ("pixman" ,pixman)
+ ("wayland" ,wayland)))
(arguments
`(#:configure-flags
(list