summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-07-24 23:57:29 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-07-24 23:59:07 +0200
commitc7b51b799dcbbee53d6eb8b615f5fd9e29b68856 (patch)
tree7172d13ba748da9a152ca2cbc102380756a7dd91 /gnu
parente463e09dc2b5ef6c19ae9dbb11f1caeb8336bbf7 (diff)
downloadguix-patches-c7b51b799dcbbee53d6eb8b615f5fd9e29b68856.tar
guix-patches-c7b51b799dcbbee53d6eb8b615f5fd9e29b68856.tar.gz
gnu: esmtp: Fix build with libesmtp >= 1.1.0.
* gnu/packages/mail.scm (esmtp)[source]: Add patch. * gnu/packages/patches/esmtp-add-lesmtp.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/mail.scm3
-rw-r--r--gnu/packages/patches/esmtp-add-lesmtp.patch37
3 files changed, 40 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 38b3c80155..a5ee3097de 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -997,6 +997,7 @@ dist_patch_DATA = \
%D%/packages/patches/enjarify-setup-py.patch \
%D%/packages/patches/enlightenment-fix-setuid-path.patch \
%D%/packages/patches/erlang-man-path.patch \
+ %D%/packages/patches/esmtp-add-lesmtp.patch \
%D%/packages/patches/eudev-rules-directory.patch \
%D%/packages/patches/evilwm-lost-focus-bug.patch \
%D%/packages/patches/evolution-CVE-2020-11879.patch \
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index f0f1540cc9..e400b8cb6b 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -2399,7 +2399,8 @@ be expected from a simple client.")
(sha256
(base32
"1ay282rrl92h0m0m8z5zzjnwiiagi7c78aq2qvhia5mw7prwfyw2"))
- (file-name (string-append name "-" version "-checkout"))))
+ (file-name (string-append name "-" version "-checkout"))
+ (patches (search-patches "esmtp-add-lesmtp.patch"))))
(arguments
`(#:phases (modify-phases %standard-phases
(replace 'bootstrap
diff --git a/gnu/packages/patches/esmtp-add-lesmtp.patch b/gnu/packages/patches/esmtp-add-lesmtp.patch
new file mode 100644
index 0000000000..eb863cd397
--- /dev/null
+++ b/gnu/packages/patches/esmtp-add-lesmtp.patch
@@ -0,0 +1,37 @@
+From 9b09ff673954c459218e2c664386286ca68aae51 Mon Sep 17 00:00:00 2001
+From: Tobias Geerinckx-Rice <me@tobias.gr>
+Date: Sat, 24 Jul 2021 23:55:26 +0200
+Subject: [PATCH] gnu: esmtp: Always assume that -lesmtp will work.
+
+libesmtp 1.1.0 removed the libesmtp-config helper in favour of pkg-config.
+This does not use that (I lack the chops and the patience). Assume that
+the build environment has everything set up for us, which is true on Guix.
+---
+ configure.ac | 11 ++---------
+ 1 file changed, 2 insertions(+), 9 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 9252ec2..7ccf71a 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -32,15 +32,8 @@ then
+ AC_CHECK_HEADER(libesmtp.h, ,[AC_MSG_ERROR([libesmtp.h not found in $with_libesmtp])])
+ fi
+ AC_MSG_CHECKING(for libESMTP)
+-if libesmtp-config --version > /dev/null 2>&1
+-then
+- AC_MSG_RESULT(yes)
+- CFLAGS="$CFLAGS `libesmtp-config --cflags`"
+- LIBS="$LIBS `libesmtp-config --libs`"
+-else
+- AC_MSG_RESULT(no)
+- AC_MSG_ERROR(libESMTP library not found)
+-fi
++AC_MSG_RESULT(assumed)
++LIBS="$LIBS -lesmtp"
+
+ jrf_FUNC_GETOPT
+
+--
+2.32.0
+