summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-05-26 21:43:59 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-07-22 11:37:25 +0200
commit9cfa6c3c587766a310252f4c1271503d819bdd8a (patch)
tree8dd2fa11ec099e68fc278c6d5c62b4cad94f4823 /gnu
parent2b6dd1bde5bac375d61da8ead1efdf9a164aa787 (diff)
downloadguix-patches-9cfa6c3c587766a310252f4c1271503d819bdd8a.tar
guix-patches-9cfa6c3c587766a310252f4c1271503d819bdd8a.tar.gz
gnu: Add r-opencpu
* gnu/packages/cran.scm: (r-opencpu): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 0558eb2452..f2bf36bb36 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -29856,3 +29856,46 @@ is optimized at compile time. The @code{RProtoBuf} package on the other hand
uses the protobuf runtime library to provide a general-purpose toolkit for
reading and writing arbitrary protocol-buffer data in R.")
(license license:expat)))
+
+(define-public r-opencpu
+ (package
+ (name "r-opencpu")
+ (version "2.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "opencpu" version))
+ (sha256
+ (base32 "0dr3ga8vw10vllqjq6n53dwivvgvzrgrjcn17kmabp620533bj1k"))))
+ (properties `((upstream-name . "opencpu")))
+ (build-system r-build-system)
+ (inputs
+ `(("pandoc" ,pandoc)))
+ (propagated-inputs
+ `(("r-brew" ,r-brew)
+ ("r-curl" ,r-curl)
+ ("r-evaluate" ,r-evaluate)
+ ("r-httpuv" ,r-httpuv)
+ ("r-jsonlite" ,r-jsonlite)
+ ("r-knitr" ,r-knitr)
+ ("r-mime" ,r-mime)
+ ("r-openssl" ,r-openssl)
+ ("r-protolite" ,r-protolite)
+ ("r-rappdirs" ,r-rappdirs)
+ ("r-remotes" ,r-remotes)
+ ("r-sys" ,r-sys)
+ ("r-webutils" ,r-webutils)
+ ("r-zip" ,r-zip)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://www.opencpu.org")
+ (synopsis "API for embedded scientific computing")
+ (description
+ "This package provides a system for embedded scientific computing and
+reproducible research with R. The OpenCPU server exposes a simple but
+powerful HTTP API for RPC and data interchange with R. This provides a
+reliable and scalable foundation for statistical services or building R web
+applications. The OpenCPU server runs either as a single-user development
+server within the interactive R session, or as a multi-user stack based on
+Apache2.")
+ (license license:asl2.0)))