summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-10-19 00:07:28 +0200
committerLudovic Courtès <ludo@gnu.org>2013-10-19 00:07:28 +0200
commitd038cac12ac8d48a79b79653e8dd876a3fffae3c (patch)
treee63a75a17517e104a6bb4415a87fecb11d4f49ed /gnu
parent02c72d167116fb56360cbe7f9b80a8b33284ae6f (diff)
downloadguix-patches-d038cac12ac8d48a79b79653e8dd876a3fffae3c.tar
guix-patches-d038cac12ac8d48a79b79653e8dd876a3fffae3c.tar.gz
gnu: Add GNU Alive.
* gnu/packages/system.scm (alive): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/system.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/system.scm b/gnu/packages/system.scm
index 019af78024..9c06e6b61e 100644
--- a/gnu/packages/system.scm
+++ b/gnu/packages/system.scm
@@ -321,3 +321,25 @@ programs and scripts. At the same time, it is a feature-rich network debugging
and exploration tool, since it can create almost any kind of connection you
would need and has several interesting built-in capabilities.")
(license gpl2+)))
+
+(define-public alive
+ (package
+ (name "alive")
+ (version "2.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/alive/alive-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1vrzg51ai68x9yld7vbgl58sxaw5qpx8rbakwcxn4cqq6vpxj38j"))))
+ (build-system gnu-build-system)
+ (arguments '(#:configure-flags '("alive_cv_nice_ping=yes")))
+ (inputs `(("guile" ,guile-2.0)
+ ("inetutils" ,inetutils)))
+ (home-page "http://www.gnu.org/software/alive/")
+ (synopsis "Autologin and keep-alive daemon")
+ (description
+ "GNU Alive sends periodic pings to a server, generally to keep a
+connection alive.")
+ (license gpl3+)))