summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-10-10 22:16:58 +0200
committerLudovic Courtès <ludo@gnu.org>2013-10-10 22:16:58 +0200
commitcdecf775011498fabb1f484d59b626e0f1ee408c (patch)
tree1c7a5f0f89c56fc29c1117f35419689d9cf4f3f5 /gnu
parentfb6c2fa82e1499e6cba8ac860bc0f4902d1ff9ea (diff)
downloadguix-patches-cdecf775011498fabb1f484d59b626e0f1ee408c.tar
guix-patches-cdecf775011498fabb1f484d59b626e0f1ee408c.tar.gz
gnu: tar: Update to 1.17.
* gnu/packages/base.scm (tar): Update to 1.17. Remove 'arguments' and 'inputs'. * gnu/packages/patches/tar-gets-undeclared.patch: Remove. * gnu-system.am (dist_patch_DATA): Remove 'tar-gets-undeclared.patch'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/base.scm7
-rw-r--r--gnu/packages/patches/tar-gets-undeclared.patch26
2 files changed, 2 insertions, 31 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 8cee8f850b..17166752fd 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -130,18 +130,15 @@ is often used for substituting text patterns in a stream.")
(define-public tar
(package
(name "tar")
- (version "1.26")
+ (version "1.27")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/tar/tar-"
version ".tar.bz2"))
(sha256
(base32
- "0hbdkzmchq9ycr2x1pxqdcgdbaxksh8c6ac0jf75jajhcks6jlss"))))
+ "0yrwmx2f721ahpnki4fnzvnmrd3md3bq417icb4wrjky7k3caf12"))))
(build-system gnu-build-system)
- (inputs `(("patch/gets" ,(search-patch "tar-gets-undeclared.patch"))))
- (arguments
- `(#:patches (list (assoc-ref %build-inputs "patch/gets"))))
(synopsis "Managing tar archives")
(description
"Tar provides the ability to create tar archives, as well as the
diff --git a/gnu/packages/patches/tar-gets-undeclared.patch b/gnu/packages/patches/tar-gets-undeclared.patch
deleted file mode 100644
index 301a09dde1..0000000000
--- a/gnu/packages/patches/tar-gets-undeclared.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-This patch is needed to allow builds with newer versions of
-the GNU libc (2.16+).
-
-This is a backport of this patch:
-
-commit 66712c23388e93e5c518ebc8515140fa0c807348
-Author: Eric Blake <eblake@redhat.com>
-Date: Thu Mar 29 13:30:41 2012 -0600
-
- stdio: don't assume gets any more
-
---- tar-1.26/gnu/stdio.in.h 2012-07-02 14:28:45.000000000 +0200
-+++ tar-1.26/gnu/stdio.in.h 2012-07-02 14:28:50.000000000 +0200
-@@ -160,12 +160,6 @@ _GL_WARN_ON_USE (fflush, "fflush is not
- "use gnulib module fflush for portable POSIX compliance");
- #endif
-
--/* It is very rare that the developer ever has full control of stdin,
-- so any use of gets warrants an unconditional warning. Assume it is
-- always declared, since it is required by C89. */
--#undef gets
--_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
--
- #if @GNULIB_FOPEN@
- # if @REPLACE_FOPEN@
- # if !(defined __cplusplus && defined GNULIB_NAMESPACE)