summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-10-17 22:43:27 +0200
committerLudovic Courtès <ludo@gnu.org>2013-10-17 23:50:31 +0200
commit9167f8e6f9fe2a7f8765ce261033c208f1810cb2 (patch)
treebbb6e7b570a5b1445979fb3aff5020454e46a7cf /gnu
parent515e68782f871a39586ba779137d10c13fa5cde2 (diff)
downloadguix-patches-9167f8e6f9fe2a7f8765ce261033c208f1810cb2.tar
guix-patches-9167f8e6f9fe2a7f8765ce261033c208f1810cb2.tar.gz
gnu: Add shared-mime-info.
* gnu/packages/gnome.scm (shared-mime-info): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 16e491d3ed..4ae2891f04 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -264,6 +264,37 @@ GNOME and KDE desktops to the icon names proposed in the specification.")
"Icons for the GNOME desktop.")
(license lgpl3))) ; or Creative Commons BY-SA 3.0
+(define-public shared-mime-info
+ (package
+ (name "shared-mime-info")
+ (version "1.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://freedesktop.org/~hadess/shared-mime-info-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "0y5vi0vr6rbhvfzcfg57cfskn362bpvcpca9cy598nmr87i6lld5"))))
+ (build-system gnu-build-system)
+ (arguments
+ ;; The build system appears not to be parallel-safe.
+ '(#:parallel-build? #f))
+ (inputs
+ `(("glib" ,glib)
+ ("libxml2" ,libxml2)
+ ("pkg-config" ,pkg-config)))
+ (native-inputs
+ `(("intltool" ,intltool)))
+ (home-page "http://freedesktop.org/wiki/Software/shared-mime-info")
+ (synopsis "Database of common MIME types")
+ (description
+ "The shared-mime-info package contains the core database of common types
+and the update-mime-database command used to extend it. It requires glib2 to
+be installed for building the update command. Additionally, it uses intltool
+for translations, though this is only a dependency for the maintainers. This
+database is translated at Transifex.")
+ (license gpl2+)))
+
(define-public hicolor-icon-theme
(package
(name "hicolor-icon-theme")