summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-07-19 12:39:57 +0200
committerAndreas Enge <andreas@enge.fr>2015-07-22 19:29:17 +0200
commit1436c5c7e8a4a1f49e1d041646ba3b10a1302487 (patch)
treef62e0329575fec545ba92c98eaa923044a0735d8 /gnu
parent8fd3c1ff6e9ca0084d4ac6c2c515da093b2a7664 (diff)
downloadguix-patches-1436c5c7e8a4a1f49e1d041646ba3b10a1302487.tar
guix-patches-1436c5c7e8a4a1f49e1d041646ba3b10a1302487.tar.gz
gnu: teckit: Update to 2.5.4.
* gnu/packages/fontutils.scm (teckit): Update to 2.5.4. Drop patch. Use svn-fetch for download. [arguments]: Add phase to call autogen. [native-inputs]: New field. * gnu/packages/patches/teckit-cstdio.patch: Delete file. * gnu-system.am (dist_patch_DATA): Unregister patch.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/fontutils.scm43
-rw-r--r--gnu/packages/patches/teckit-cstdio.patch10
2 files changed, 25 insertions, 28 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 5953caa87a..8b5346a17f 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -34,6 +34,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix svn-download)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu))
@@ -139,27 +140,33 @@ X11-system or any other graphical user interface.")
(define-public teckit
(package
(name "teckit")
- (version "2.5.1")
+ (version "2.5.4")
(source (origin
- (method url-fetch)
- (uri (list
- (string-append
- "http://scripts.sil.org/svn-view/teckit/TAGS/TECkit_"
- (string-map (lambda (x) (if (char=? x #\.) #\_ x)) version)
- ".tar.gz")
- "http://pkgs.fedoraproject.org/repo/pkgs/teckit/TECkit_2_5_1.tar.gz/4913f71f0f42bfd9cf8f161688b35dea/TECkit_2_5_1.tar.gz"
- ;; This used to be the canonical URL but it vanished.
- ;; See <http://bugs.gnu.org/19600>.
- ;; (string-append
- ;; "http://scripts.sil.org/svn-view/teckit/TAGS/TECkit_"
- ;; (string-map (lambda (x) (if (char=? x #\.) #\_ x)) version)
- ;; ".tar.gz")
- ))
- (sha256 (base32
- "0fjiwvic8mdxpkyccfp7zh26y9xnvkp0skqbyfkrjiacd191k82r"))
- (patches (list (search-patch "teckit-cstdio.patch")))))
+ ;; Downloaded tarballs vary with each download, so we use an
+ ;; svn snapshot. The 2.5.4 release seems to be made in r128,
+ ;; but r132 updates additional files to contain the correct
+ ;; version number (r129 to r131 do not concern TRUNK).
+ (method svn-fetch)
+ (uri (svn-reference
+ (url "https://scripts.sil.org/svn-public/teckit/TRUNK")
+ (revision 132)))
+ (file-name (string-append name "-" version))
+ (sha256
+ (base32
+ "1xqkqgw30pb24snh46srmjs2j4zhz2dfi5pf7znia0k34mrpwivz"))))
(build-system gnu-build-system)
(inputs `(("zlib" ,zlib)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("perl" ,perl))) ; for the tests
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'autogen
+ (lambda _
+ (zero? (system* "sh" "autogen.sh")))))))
(synopsis "Toolkit for encoding conversions")
(description
"TECkit is a low-level toolkit intended to be used by other applications
diff --git a/gnu/packages/patches/teckit-cstdio.patch b/gnu/packages/patches/teckit-cstdio.patch
deleted file mode 100644
index d79595ed44..0000000000
--- a/gnu/packages/patches/teckit-cstdio.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- TECkit_2_5_1/source/Compiler.cpp 2008-04-07 16:21:12.000000000 +0200
-+++ TECkit_2_5_1/source/Compiler.cpp 2013-01-26 00:33:18.000000000 +0100
-@@ -29,6 +29,7 @@
-
- #include "Compiler.h"
-
-+#include <cstdio>
- #include <iostream>
- #include <iomanip>
- #include <algorithm>