summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-12 19:24:56 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:32 +0100
commit4c8a1f4030998dc9020d062352c9fd1f9fb798bd (patch)
treeffe72058cef0c050480b11d80ee86e58b896daa2 /gnu
parent40a6d7a2f6452cfc468ce0dfc4da9661ff1170ca (diff)
downloadguix-patches-4c8a1f4030998dc9020d062352c9fd1f9fb798bd.tar
guix-patches-4c8a1f4030998dc9020d062352c9fd1f9fb798bd.tar.gz
gnu: ghc-vector: Update to 0.12.0.1.
* gnu/packages/haskell.scm (ghc-vector): Update to 0.12.0.1.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm17
1 files changed, 12 insertions, 5 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index c9d8c770e1..34f630205b 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -3146,7 +3146,7 @@ is also parametric in the input stream type.")
(define-public ghc-vector
(package
(name "ghc-vector")
- (version "0.11.0.0")
+ (version "0.12.0.1")
(outputs '("out" "doc"))
(source
(origin
@@ -3157,13 +3157,20 @@ is also parametric in the input stream type.")
".tar.gz"))
(sha256
(base32
- "1r1jlksy7b0kb0fy00g64isk6nyd9wzzdq31gx5v1wn38knj0lqa"))))
+ "0yrx2ypiaxahvaz84af5bi855hd3107kxkbqc8km29nsp5wyw05i"))))
(build-system haskell-build-system)
+ ;; FIXME: To simplify upgrading all Haskell packages, we leave the tests
+ ;; disabled for now.
+ (arguments `(#:tests? #f))
(inputs
`(("ghc-primitive" ,ghc-primitive)
- ("ghc-quickcheck" ,ghc-quickcheck)))
- (arguments
- `(#:tests? #f)) ; FIXME: currently missing libraries used for tests.
+ ("ghc-random" ,ghc-random)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ;; ("ghc-hunit" ,ghc-hunit)
+ ;; ("ghc-test-framework" ,ghc-test-framework)
+ ;; ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)
+ ;; ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)
+ ))
(home-page "https://github.com/haskell/vector")
(synopsis "Efficient Arrays")
(description "This library provides an efficient implementation of