summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-04-19 20:58:59 +0200
committerLudovic Courtès <ludo@gnu.org>2019-05-06 11:09:10 +0200
commitdf7d0dce4b2d23853feb111bd6a7dda09c722232 (patch)
tree64c2888f3ce8251bec0fa0a52d99625d55ed5351 /gnu
parenta08530df08b943f2131873e9f86e326477dfa1c7 (diff)
downloadguix-patches-df7d0dce4b2d23853feb111bd6a7dda09c722232.tar
guix-patches-df7d0dce4b2d23853feb111bd6a7dda09c722232.tar.gz
gnu: Add emacs-evil-textobj-syntax.
* gnu/packages/emacs-xyz.scm (emacs-evil-textobj-syntax): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b33502fc2a..18bc87ed4a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2743,6 +2743,33 @@ the speedbar window.")
"This package provides a macro that writes your namespaces for you.")
(license license:gpl3+))))
+(define-public emacs-evil-textobj-syntax
+ (let ((commit "2d9ba8c75c754b409aea7469f46a5cfa52a872f3")
+ (version "0")
+ (revision "1"))
+ (package
+ (name "emacs-evil-textobj-syntax")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/laishulu/evil-textobj-syntax/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "031p5i3274dazp7rz6m5y38shfgszm1clmkcf58qfqlvy978ammc"))))
+ (build-system emacs-build-system)
+ (propagated-inputs `(("emacs-evil" ,emacs-evil)
+ ("emacs-names" ,emacs-names)))
+ (home-page "https://github.com/laishulu/evil-textobj-syntax/")
+ (synopsis "Text objects based on syntax highlighting")
+ (description
+ "This package provides text objects for @code{evil-mode} with
+boundaries defined by syntax highlighting.")
+ (license license:gpl3+))))
+
(define-public emacs-ob-ipython
(package
(name "emacs-ob-ipython")