summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-09-16 11:01:34 +0200
committerDavid Thompson <dthompson2@worcester.edu>2015-09-19 08:49:11 -0400
commitd152162fc1bbd1dea4379239537cde7ca893880a (patch)
tree57d274082074678a033288582ec52d7ee48e2356 /gnu
parentc5d14d42282fe9d4123f1efa0f995123781e17da (diff)
downloadguix-patches-d152162fc1bbd1dea4379239537cde7ca893880a.tar
guix-patches-d152162fc1bbd1dea4379239537cde7ca893880a.tar.gz
gnu: Add ruby-notiffany.
* gnu/packages/ruby.scm (ruby-notiffany): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index e8ec6ed870..88eeb76a10 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -602,6 +602,30 @@ the output produced by running shell commands.")
(home-page "https://rubygems.org/gems/shellany")
(license license:expat)))
+(define-public ruby-notiffany
+ (package
+ (name "ruby-notiffany")
+ (version "0.0.7")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "notiffany" version))
+ (sha256
+ (base32
+ "1v5x1w59qq85r6dpv3y9ga34dfd7hka1qxyiykaw7gm0i6kggbhi"))))
+ (build-system ruby-build-system)
+ ;; Tests are not included in the gem.
+ (arguments `(#:tests? #f))
+ (propagated-inputs
+ `(("ruby-shellany" ,ruby-shellany)
+ ("ruby-nenv" ,ruby-nenv)))
+ (native-inputs
+ `(("bundler" ,bundler)))
+ (synopsis "Wrapper libray for notification libraries")
+ (description "Notiffany is a Ruby wrapper libray for notification
+libraries such as Libnotify.")
+ (home-page "https://github.com/guard/notiffany")
+ (license license:expat)))
+
(define-public ruby-useragent
(package
(name "ruby-useragent")