summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-08-31 22:54:14 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-08-31 23:11:05 +0200
commitc4f500d03211d7b4763a5443275e18b54e55f44c (patch)
tree7e529582acac79c90e979edc8fbc2fb0a6617c04 /gnu
parent73995969b133e50c04ad8f1e8a1428aef0eadb43 (diff)
downloadguix-patches-c4f500d03211d7b4763a5443275e18b54e55f44c.tar
guix-patches-c4f500d03211d7b4763a5443275e18b54e55f44c.tar.gz
gnu: python-anyio: Avoid failing tests.
* gnu/packages/python-xyz.scm (python-anyio)[arguments]: Disable asyncio plugin, and explicitly disable network tests.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 07c9127c19..7be4b6a1ff 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23066,7 +23066,9 @@ standard error channel (stderr) in your program.")
(lambda* (#:key inputs outputs tests? #:allow-other-keys)
(when tests?
(add-installed-pythonpath inputs outputs)
- (invoke "pytest" "-vv" "-k"
+ (invoke "pytest" "-vv" "-p" "no:asyncio"
+ "-m" "not network"
+ "-k"
(string-append
"not test_is_block_device"