summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-10 16:48:05 +0200
committerMarius Bakke <marius@gnu.org>2021-05-13 17:03:47 +0200
commitbc0a78c003c63bf6886bc29f786a8ee82e95acff (patch)
tree4410f2cbcfe618ea52d9b81a94e9108b089e2df3 /gnu
parent09a1e17dfa55ed96a4996bd95c219f316c5ff85f (diff)
downloadguix-patches-bc0a78c003c63bf6886bc29f786a8ee82e95acff.tar
guix-patches-bc0a78c003c63bf6886bc29f786a8ee82e95acff.tar.gz
gnu: Fix references to unbound variables.
This is a follow-up to f03426420497cd9839f5fb3cb547dbecd8d6053b which introduced new packages that refer to variables that no longer exist. * gnu/packages/python-xyz.scm (python-fastjsonschema)[native-inputs]: Change from PYTHON-PYTEST-6 to PYTHON-PYTEST. (python-nbconvert)[native-inputs]: Change from TEXLIVE-UNION to TEXLIVE-UPDMAP.CFG. * gnu/packages/shells.scm (nushell)[arguments]: Remove #:rust.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm4
-rw-r--r--gnu/packages/shells.scm3
2 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0c06b32907..eebb44b9dc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10673,7 +10673,7 @@ JSON Reference and JSON Pointer.")
("python-json-spec" ,python-json-spec)
("python-jsonschema" ,python-jsonschema)
("python-pylint" ,python-pylint)
- ("python-pytest" ,python-pytest-6)
+ ("python-pytest" ,python-pytest)
("python-pytest-benchmark"
,python-pytest-benchmark)
("python-pytest-cache" ,python-pytest-cache)
@@ -10954,7 +10954,7 @@ time.")
("python-pytest" ,python-pytest)
("python-pytest-cov" ,python-pytest-cov)
("python-pytest-dependency" ,python-pytest-dependency)
- ("texlive" ,(texlive-union (list texlive-adjustbox
+ ("texlive" ,(texlive-updmap.cfg (list texlive-adjustbox
texlive-amsfonts/patched
texlive-booktabs
texlive-caption
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index b9b3c58f0c..57b1a41111 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -968,8 +968,7 @@ files and text.")
(base32 "0x7r8ipvypf6py2h03pdqr8pal6vyp6mskvss1rr8f0bcy3gr725"))))
(build-system cargo-build-system)
(arguments
- `(#:rust ,rust-1.47
- #:tests? #false ;missing files
+ `(#:tests? #false ;missing files
#:features '("extra")
#:cargo-inputs
(("rust-clap" ,rust-clap-2)