summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-04-02 16:20:24 -0500
committerEric Bavier <bavier@member.fsf.org>2015-04-04 00:46:03 -0500
commitb56a918f77013d421cf9b0c8bfde547a637f6b61 (patch)
tree7365b0ebf0cd589117b0753d21b987b356bf88c3 /gnu
parentf7ee7a9b06a386863d7752ba028a79bb98d3504d (diff)
downloadguix-patches-b56a918f77013d421cf9b0c8bfde547a637f6b61.tar
guix-patches-b56a918f77013d421cf9b0c8bfde547a637f6b61.tar.gz
gnu: Add PerlMagick.
* gnu/packages/imagemagick.scm (perl-image-magick): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/imagemagick.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/imagemagick.scm b/gnu/packages/imagemagick.scm
index 0144212b3e..2a68627dc6 100644
--- a/gnu/packages/imagemagick.scm
+++ b/gnu/packages/imagemagick.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -19,6 +20,7 @@
(define-module (gnu packages imagemagick)
#:use-module (guix packages)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system perl)
#:use-module (guix download)
#:use-module ((guix licenses) #:select (fsf-free))
#:use-module (gnu packages algebra)
@@ -90,3 +92,47 @@ and TIFF. Use ImageMagick to resize, flip, mirror, rotate, distort, shear and
transform images, adjust image colors, apply various special effects, or draw
text, lines, polygons, ellipses and Bézier curves.")
(license (fsf-free "http://www.imagemagick.org/script/license.php"))))
+
+(define-public perl-image-magick
+ (package
+ (name "perl-image-magick")
+ (version "6.89")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/J/JC/JCRISTY/"
+ "PerlMagick-" version "-1.tar.gz"))
+ (sha256
+ (base32
+ "0n9afy1z5bhf9phrbahnkwhgcmijn8jggpbzwrivw1zhliliiy68"))))
+ (build-system perl-build-system)
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (inputs `(("imagemagick" ,imagemagick)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before
+ configure image-magick-flags
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((im (assoc-ref inputs "imagemagick")))
+ (substitute* "Makefile.PL"
+ (("my \\$INC_magick = .*")
+ "my $INC_magick = `pkg-config --cflags ImageMagick`;\n")
+ (("my \\$LIBS_magick = .*")
+ "my $LIBS_magick = `pkg-config --libs ImageMagick`;\n")))))
+ (add-before
+ check skip-mpeg-tests
+ (lambda _
+ ;; TODO: MPEG tests fail even though our imagemagick supports
+ ;; MPEG. Has been reported elsewhere,
+ ;; http://www.imagemagick.org/discourse-server/viewtopic.php?f=7&t=25036,
+ ;; so skip for now.
+ (delete-file "t/mpeg/read.t"))))))
+ (home-page "http://search.cpan.org/dist/PerlMagick")
+ (synopsis "Perl interface to ImageMagick")
+ (description "This Perl extension allows the reading, manipulation and
+writing of a large number of image file formats using the ImageMagick library.
+Use it to create, edit, compose, or convert bitmap images from within a Perl
+script.")
+ ;; See Magick.pm
+ (license (package-license imagemagick))))