summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-09-01 21:37:12 +0200
committerRicardo Wurmus <rekado@elephly.net>2015-09-21 07:31:42 +0200
commitaf8f9f231ef49ba49fc75e4f5f123a62893fe670 (patch)
tree4f08d46aedd2f0b0a048bcbbee3fed89d10dbfe7 /gnu
parentda494dad8e97c3241cf7702438b0047d502e551e (diff)
downloadguix-patches-af8f9f231ef49ba49fc75e4f5f123a62893fe670.tar
guix-patches-af8f9f231ef49ba49fc75e4f5f123a62893fe670.tar.gz
gnu: Add libgee.
* gnu/packages/gnome.scm (libgee): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ca75fa82e0..73d8a4fb9d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3500,3 +3500,40 @@ manage, and publish documentation for Yelp and the web. Most of the heavy
lifting is done by packages like yelp-xsl and itstool. This package just
wraps things up in a developer-friendly way.")
(license license:gpl2+)))
+
+(define-public libgee
+ (package
+ (name "libgee")
+ (version "0.18.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "16a34js81w9m2bw4qd8csm4pcgr3zq5z87867j4b8wfh6zwrxnaa"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-introspection-install-dir
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "gee/Makefile.in"
+ (("@INTROSPECTION_GIRDIR@")
+ (string-append out "/share/gir-1.0/"))
+ (("@INTROSPECTION_TYPELIBDIR@")
+ (string-append out "/lib/girepository-1.0/")))))))))
+ (native-inputs
+ `(("glib" ,glib "bin")
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("glib" ,glib)
+ ("gobject-introspection" ,gobject-introspection)))
+ (home-page "https://wiki.gnome.org/Projects/Libgee")
+ (synopsis "GObject collection library")
+ (description
+ "Libgee is a utility library providing GObject-based interfaces and
+classes for commonly used data structures.")
+ (license license:lgpl2.1+)))