summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-09-04 18:06:10 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-09-04 22:09:02 +0200
commit039eb73b66e36fee9351fba61baf68692bcb409d (patch)
treebf725508ade0a9323ce58883d5c756f55d387262 /gnu
parent63602129947192a2564bbd8aa894a55265a187ad (diff)
downloadguix-patches-039eb73b66e36fee9351fba61baf68692bcb409d.tar
guix-patches-039eb73b66e36fee9351fba61baf68692bcb409d.tar.gz
gnu: fbcat: Update to 0.5.2.
* gnu/packages/linux.scm (fbcat): Update to 0.5.2. [arguments]: Don't return #t from phases.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index fbe6d42336..5c154a9277 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7275,14 +7275,14 @@ relevant @file{/dev/vcs*} file(s).")
(define-public fbcat
(package
(name "fbcat")
- (version "0.5.1")
+ (version "0.5.2")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/jwilk/fbcat/releases/download/"
version "/" name "-" version ".tar.gz"))
(sha256
- (base32 "0pj9hxmwhbz6kmd7847yx2jh1scl9l25zgndyi8s9vlzdkq2q8d7"))))
+ (base32 "07q6f0xj7b4gjvn69qfn0g04yd0ch8ndzyigcz8nnrhli0cvsbh6"))))
(build-system gnu-build-system)
(inputs
;; The ‘fbgrab’ wrapper can use one of several PPM-to-PNG converters. We
@@ -7306,8 +7306,7 @@ relevant @file{/dev/vcs*} file(s).")
(("fbcat" all)
(string-append out "/bin/" all))
(("pnmtopng" all)
- (string-append pnmtopng "/bin/" all)))
- #t)))
+ (string-append pnmtopng "/bin/" all))))))
(add-after 'install 'split-fbgrab-output
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -7318,8 +7317,7 @@ relevant @file{/dev/vcs*} file(s).")
(mkdir-p (dirname new))
(rename-file old new)))
(list "bin/fbgrab"
- "share/man/man1/fbgrab.1"))
- #t))))))
+ "share/man/man1/fbgrab.1"))))))))
(home-page "https://jwilk.net/software/fbcat")
(synopsis "Take a screenshot of the contents of the Linux framebuffer")
(description