summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-10-18 13:30:18 +0800
committer宋文武 <iyzsong@gmail.com>2015-10-18 13:30:18 +0800
commit4955ab7d651b24915b99de96587d516401c8db5e (patch)
tree0483bcc3a8b14a38153be592e21f66e55117d450 /gnu
parent7765bfc61f60e2aa3cbbb37b02bb66231667760a (diff)
downloadguix-patches-4955ab7d651b24915b99de96587d516401c8db5e.tar
guix-patches-4955ab7d651b24915b99de96587d516401c8db5e.tar.gz
gnu: json-glib: Update to 1.0.4, fix test.
* gnu/packages/gnome.scm (json-glib): Update to 1.0.4. [source]: Add snippet.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index a5cb7312d3..9a82762372 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1775,7 +1775,7 @@ configuration storage systems.")
(define-public json-glib
(package
(name "json-glib")
- (version "1.0.2")
+ (version "1.0.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -1783,7 +1783,14 @@ configuration storage systems.")
name "-" version ".tar.xz"))
(sha256
(base32
- "02k66lpc4cmgygj66n8zcy59bggy7yzm3v4hni9xqplgva9d2yw8"))))
+ "1k85vvb2prmk8aa8hmr2rp9rnbhffjgnmr18b13g24xxnqy5kww0"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Don't duplicate test names.
+ ;; <https://bugzilla.gnome.org/show_bug.cgi?id=755977>.
+ '(substitute* "json-glib/tests/builder.c"
+ (("\"/builder/complex\", test_builder_empty")
+ "\"/builder/empty\", test_builder_empty")))))
(build-system gnu-build-system)
(native-inputs
`(("glib" ,glib "bin") ;for glib-mkenums and glib-genmarshal