summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMartin Becze <mjbecze@riseup.net>2019-10-01 17:37:05 -0400
committerEfraim Flashner <efraim@flashner.co.il>2020-06-23 15:11:08 +0300
commitd6bae2b7bcc2a416c5b349b2b921725442239835 (patch)
tree831c07171685b6f54791bb127f177fbffd3a9a71 /gnu
parentc03cefc3d8dd826c4a74abbfe2b235525dca50fb (diff)
downloadguix-patches-d6bae2b7bcc2a416c5b349b2b921725442239835.tar
guix-patches-d6bae2b7bcc2a416c5b349b2b921725442239835.tar.gz
gnu: Add go-github-com-danwakefield-fnmatch.
* gnu/packages/golang.scm (go-github-com-danwakefield-fnmatch): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index a3b1c6c643..4456db0c99 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3615,6 +3615,31 @@ sensors).")
(home-page "https://github.com/shirou/gopsutil")
(license license:bsd-3))))
+(define-public go-github-com-danwakefield-fnmatch
+ (let ((commit "cbb64ac3d964b81592e64f957ad53df015803288")
+ (revision "0"))
+ (package
+ (name "go-github-com-danwakefield-fnmatch")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/danwakefield/fnmatch")
+ (commit commit)))
+ (sha256
+ (base32
+ "0cbf511ppsa6hf59mdl7nbyn2b2n71y0bpkzbmfkdqjhanqh1lqz"))
+ (file-name (git-file-name name version))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/danwakefield/fnmatch"))
+ (home-page "https://github.com/danwakefield/fnmatch")
+ (synopsis "Updated clone of kballards golang fnmatch gist")
+ (description "This package provides an updated clone of kballards golang
+fnmatch gist (https://gist.github.com/kballard/272720).")
+ (license license:bsd-2))))
+
(define-public go-github-com-fatih-color
(package
(name "go-github-com-fatih-color")