summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMartin Becze <mjbecze@riseup.net>2019-10-01 17:37:07 -0400
committerEfraim Flashner <efraim@flashner.co.il>2020-06-23 15:11:08 +0300
commit48ee9aa4614363e3e411bc8603babeb5e9f19df3 (patch)
tree6f8e769ed22674ea0966aea81ba296bfac6e189e /gnu
parentbffb8f3c5f4b660675fd764a24b40d7865f6d6d7 (diff)
downloadguix-patches-48ee9aa4614363e3e411bc8603babeb5e9f19df3.tar
guix-patches-48ee9aa4614363e3e411bc8603babeb5e9f19df3.tar.gz
gnu: Add go-github-com-emersion-go-imap.
* gnu/packages/golang.scm (go-github-com-emersion-go-imap): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index f092066972..51851a4a23 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3667,6 +3667,31 @@ fnmatch gist (https://gist.github.com/kballard/272720).")
"This is a fork of another go-libvterm library for use with aerc.")
(license license:expat))))
+(define-public go-github-com-emersion-go-imap
+ (package
+ (name "go-github-com-emersion-go-imap")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emersion/go-imap")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "1id8j2d0rn9sj8y62xhyygqpk5ygrcl9jlfx92sm1jsvxsm3kywq"))
+ (file-name (git-file-name name version))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/emersion/go-imap"))
+ (native-inputs
+ `(("go-golang-org-x-text" ,go-golang-org-x-text)))
+ (home-page "https://github.com/emersion/go-imap")
+ (synopsis "IMAP4rev1 library written in Go")
+ (description "This package provides an IMAP4rev1 library written in Go. It
+can be used to build a client and/or a server.")
+ (license license:expat)))
+
(define-public go-github-com-fatih-color
(package
(name "go-github-com-fatih-color")