summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-07-20 10:43:52 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-07-21 13:36:07 +0200
commit117988b7ca1d186873a86ae2cb9c1cba7f247c1d (patch)
treef1367ad893d63468c22cde853dd829e320a5dff5 /gnu
parent2925d8419682ee84cb13781380fefca635e2954a (diff)
downloadguix-patches-117988b7ca1d186873a86ae2cb9c1cba7f247c1d.tar
guix-patches-117988b7ca1d186873a86ae2cb9c1cba7f247c1d.tar.gz
gnu: Add r-rmisc.
* gnu/packages/cran.scm (r-rmisc): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 14177e3a23..d7ae9b8b1d 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -29777,3 +29777,24 @@ step, then reads the values lazily, so only the data you actually use needs to
be read. The writer formats the data in parallel and writes to disk
asynchronously from formatting.")
(license license:expat)))
+
+(define-public r-rmisc
+ (package
+ (name "r-rmisc")
+ (version "1.5")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "Rmisc" version))
+ (sha256
+ (base32
+ "1ijjhfy3v91fspid77rrkc5dkcb2lav37wc3f4k5lwrn24wzy5y8"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-plyr" ,r-plyr)
+ ("r-rcpp" ,r-rcpp)
+ ("r-lattice" ,r-lattice)))
+ (home-page "https://cran.r-project.org/web/packages/Rmisc/")
+ (synopsis "Ryan Miscellaneous")
+ (description "The Rmisc library contains functions for data analysis and
+utility operations.")
+ (license license:gpl3)))