summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorStefan Reichoer <stefan@xsteve.at>2016-09-16 21:43:32 +0200
committerLeo Famulari <leo@famulari.name>2016-09-17 19:17:54 -0400
commit4efb9c547870c61ef8971a28e6ccfaef38335ddb (patch)
treea6ab999f33526e017bd859790ea2697eb4b41d72 /gnu
parent082138e953a79d5cd1fa0d520938c39a4458eada (diff)
downloadguix-patches-4efb9c547870c61ef8971a28e6ccfaef38335ddb.tar
guix-patches-4efb9c547870c61ef8971a28e6ccfaef38335ddb.tar.gz
gnu: Add python-glances.
* gnu/packages/python.scm (python-glances, python2-glances): New variables. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 2f349c88f3..027a9f2824 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -27,6 +27,7 @@
;;; Copyright © 2016 Dylan Jeffers <sapientech@sapientech@openmailbox.org>
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2016 Stefan Reichoer <stefan@xsteve.at>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -10475,3 +10476,36 @@ functionality in the command line.")
("python2-mock" ,python2-mock)
("python2-enum34" ,python2-enum34)
,@(package-native-inputs base))))))
+
+(define-public python-glances
+ (package
+ (name "python-glances")
+ (version "2.7.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "Glances" version))
+ (sha256
+ (base32
+ "11jbq40g8alsbirnd4kiagznqg270247i0m8qhi48ldf2i5xppxg"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-psutil" ,python-psutil)))
+ (home-page
+ "https://github.com/nicolargo/glances")
+ (synopsis
+ "A cross-platform curses-based monitoring tool")
+ (description
+ "Glances is a curses-based monitoring tool for a wide variety of platforms.
+Glances uses the PsUtil library to get information from your system. It monitors
+CPU, load, memory, network bandwidth, disk I/O, disk use, and more.")
+ (license license:lgpl3+)
+ (properties `((python2-variant . ,(delay python2-glances))))))
+
+(define-public python2-glances
+ (let ((base (package-with-python2 (strip-python2-variant python-glances))))
+ (package
+ (inherit base)
+ (native-inputs
+ `(("python2-setuptools" ,python2-setuptools)
+ ,@(package-native-inputs base))))))