summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2016-09-19 11:28:50 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-09-19 15:44:18 +1000
commit4ce603058865be5e1da07cc90f4090c94e71dd9f (patch)
treeab6b2d58ba787725d7d7622d65f96024994aa16d /gnu
parentded5d02bd07077d7daa131a5edefbc164696deb8 (diff)
downloadguix-patches-4ce603058865be5e1da07cc90f4090c94e71dd9f.tar
guix-patches-4ce603058865be5e1da07cc90f4090c94e71dd9f.tar.gz
gnu: python-biopython: Update to 1.68.
* gnu/packages/bioinformatics.scm (python-biopython): Update to 1.68. [arguments]: New field.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 39a420ac3b..69ef785ec7 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -594,15 +594,21 @@ provide a coordinated and extensible framework to do computational biology.")
(define-public python-biopython
(package
(name "python-biopython")
- (version "1.66")
+ (version "1.68")
(source (origin
(method url-fetch)
;; use PyPi rather than biopython.org to ease updating
(uri (pypi-uri "biopython" version))
(sha256
(base32
- "1gdv92593klimg22icf5j9by7xiq86jnwzkpz4abaa05ylkdf6hp"))))
+ "07qc7nz0k77y8hf8s18rscvibvm91zw0kkq7ylrhisf8vp8hkp6i"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'set-home
+ ;; Some tests require a home directory to be set.
+ (lambda _ (setenv "HOME" "/tmp") #t)))))
(inputs
`(("python-numpy" ,python-numpy)))
(native-inputs