summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-09-07 20:19:32 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-09-09 17:59:36 +0200
commit589aca1c183ef1dfdef54d40fdd6a258bbcd39d0 (patch)
treee3b187f6efb492f1c8e945b5a6ccd0e0a1406954 /gnu
parent9adaf1f4085e16667a034fc58984af847cab6b05 (diff)
downloadguix-patches-589aca1c183ef1dfdef54d40fdd6a258bbcd39d0.tar
guix-patches-589aca1c183ef1dfdef54d40fdd6a258bbcd39d0.tar.gz
gnu: Python: Delete broken test.
* gnu/packages/python.scm (python-3.7)[source](snippet): Delete test which may crash some systems.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index df98778c0f..a057e2a6a3 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -342,9 +342,15 @@ data types.")
(snippet
'(begin
(for-each delete-file
- '("Lib/ctypes/test/test_win32.py" ; fails on aarch64
- "Lib/test/test_fcntl.py" ; fails on aarch64
- "Lib/test/test_posix.py")) ; fails on aarch64
+ '(;; This test may hang and eventually run out of
+ ;; memory on some systems:
+ ;; <https://bugs.python.org/issue34587>
+ "Lib/test/test_socket.py"
+
+ ;; These tests fail on AArch64.
+ "Lib/ctypes/test/test_win32.py"
+ "Lib/test/test_fcntl.py"
+ "Lib/test/test_posix.py"))
#t))))
(arguments
(substitute-keyword-arguments (package-arguments python-2)