summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-09 14:58:34 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-09 15:43:50 +0100
commitad6fea1690c2a7ce3e1998e3ab402556be0973e5 (patch)
treee316145b953a9f5fec321910b9a2f5b99be42b3b /gnu
parent9170eb7f1f62c2c79daa1d0059e285e2119db35c (diff)
downloadguix-patches-ad6fea1690c2a7ce3e1998e3ab402556be0973e5.tar
guix-patches-ad6fea1690c2a7ce3e1998e3ab402556be0973e5.tar.gz
gnu: Add r-ontologyindex.
* gnu/packages/cran.scm (r-ontologyindex): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index c11202abf7..d3c22d2350 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -9382,3 +9382,23 @@ other manipulations of bitmapped images.")
"This package provides JSON parsing capability through the Rapidjson
library.")
(license license:expat)))
+
+(define-public r-ontologyindex
+ (package
+ (name "r-ontologyindex")
+ (version "2.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ontologyIndex" version))
+ (sha256
+ (base32
+ "168m4jdwbzv8lpimx9063306691hnfdjmdhb5y8195d9vcq049jr"))))
+ (properties `((upstream-name . "ontologyIndex")))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/web/packages/ontologyIndex")
+ (synopsis "Functions for processing ontologies in R")
+ (description
+ "This package provides functions for reading ontologies into R as lists
+and manipulating sets of ontological terms.")
+ (license license:gpl2+)))