summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2018-09-24 00:37:58 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2018-10-30 20:41:50 +0100
commita75b8c08c0a28b1243680efccbe59ec5aa88795d (patch)
treee5827085af87063495198ae718a98741ae0f7e84 /gnu
parent7bf169f75cb4ffcef1393e702104eed63bc70917 (diff)
downloadguix-patches-a75b8c08c0a28b1243680efccbe59ec5aa88795d.tar
guix-patches-a75b8c08c0a28b1243680efccbe59ec5aa88795d.tar.gz
gnu: rust@1.23.0: Inherit from rust@1.22.0.
* gnu/packages/rust.scm (rust-1.23)[inherit]: Inherit from rust-1.22. [arguments]: Inherit from rust-1.22. Delete "remove-ar" phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/rust.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 7871946883..6eb71d2787 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -658,7 +658,7 @@ jemalloc = \"" jemalloc "/lib/libjemalloc_pic.a" "\"
(define-public rust-1.23
(package
- (inherit rust-1.20)
+ (inherit rust-1.22)
(name "rust")
(version "1.23.0")
(source (rust-source version "14fb8vhjzsxlbi6yrn1r6fl5dlbdd1m92dn5zj5gmzfwf4w9ar3l"))
@@ -666,12 +666,13 @@ jemalloc = \"" jemalloc "/lib/libjemalloc_pic.a" "\"
(native-inputs
(alist-replace "cargo-bootstrap" (list rust-bootstrap "cargo")
(alist-replace "rustc-bootstrap" (list rust-bootstrap)
- (package-native-inputs rust-1.20))))
+ (package-native-inputs rust-1.22))))
(arguments
- (substitute-keyword-arguments (package-arguments rust-1.20)
+ (substitute-keyword-arguments (package-arguments rust-1.22)
((#:phases phases)
`(modify-phases ,phases
(delete 'configure-archiver)
+ (delete 'remove-ar)
(add-after 'unpack 'dont-build-native
(lambda _
;; XXX: Revisit this when we use gcc 6.