summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-09 15:32:07 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-09 15:43:50 +0100
commit905aa46ae5dea7ab01a4e6e889ba56c7af4354f7 (patch)
tree49aafc4dcf23c85c19ffafba2b24de289f01f027 /gnu
parent2da2d2f60525ef87eb05753b093832f4ecd35f14 (diff)
downloadguix-patches-905aa46ae5dea7ab01a4e6e889ba56c7af4354f7.tar
guix-patches-905aa46ae5dea7ab01a4e6e889ba56c7af4354f7.tar.gz
gnu: Add r-assertive-matrices.
* gnu/packages/cran.scm (r-assertive-matrices): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 70d87c9f66..beddefe683 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -9581,3 +9581,28 @@ who want to include run-time testing features in their own packages.")
the properties of sets. This is mainly for use by other package developers
who want to include run-time testing features in their own packages.")
(license license:gpl3+)))
+
+(define-public r-assertive-matrices
+ (package
+ (name "r-assertive-matrices")
+ (version "0.0-2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "assertive.matrices" version))
+ (sha256
+ (base32
+ "16sykzcndv6y2d43x6v9n7m95kv76364h39kh10w4z0xw6ksfqil"))))
+ (properties
+ `((upstream-name . "assertive.matrices")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-assertive-base" ,r-assertive-base)))
+ (home-page "https://bitbucket.org/richierocks/assertive.matrices")
+ (synopsis "Assertions to check properties of matrices")
+ (description
+ "This package provides a set of predicates and assertions for checking
+the properties of matrices. This is mainly for use by other package
+developers who want to include run-time testing features in their own
+packages.")
+ (license license:gpl3+)))