summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-10-18 07:20:03 +0100
committerChristopher Baines <mail@cbaines.net>2017-12-09 21:12:27 +0000
commit8733fc91e07acc09df80136d0871af77984f0435 (patch)
tree08fd68edd9043c611a1ed85545c6984ceb2ca252 /gnu
parentf88c1c5d89d19f5a68d42f028eb01292e8301e2f (diff)
downloadguix-patches-8733fc91e07acc09df80136d0871af77984f0435.tar
guix-patches-8733fc91e07acc09df80136d0871af77984f0435.tar.gz
gnu: Add emacs-robe.
* gnu/packages/emacs.scm (emacs-robe): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 701953a283..77da8f2f25 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -2195,6 +2195,31 @@ tables.")
mode-line.")
(license license:gpl2+)))
+(define-public emacs-robe
+ (package
+ (name "emacs-robe")
+ (version "0.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/dgutov/robe/"
+ "archive/" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1vp45y99fwj88z04ah4yppz4z568qcib646az6m9az5ar0f203br"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-inf-ruby" ,emacs-inf-ruby)))
+ (home-page "https://github.com/dgutov/robe")
+ (synopsis "Ruby code assistance tool for Emacs")
+ (description
+ "Robe can provide information on loaded classes and modules in Ruby code,
+as well as where methods are defined. This allows the user to jump to method
+definitions, modules and classes, display method documentation and provide
+method and constant name completion.")
+ (license license:gpl3+)))
+
(define-public emacs-rspec
(package
(name "emacs-rspec")