summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-09 15:29:11 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-09 15:43:50 +0100
commit8004bb2451d33d046dfa5db3894746deaf55a285 (patch)
tree05c2d7fd07a63a9c93654467526ddacbbb12175e /gnu
parenta536c7c9ad78ce95fb8dad61114c40c57b3c0be8 (diff)
downloadguix-patches-8004bb2451d33d046dfa5db3894746deaf55a285.tar
guix-patches-8004bb2451d33d046dfa5db3894746deaf55a285.tar.gz
gnu: Add r-assertive-base.
* gnu/packages/cran.scm (r-assertive-base): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f305f2be80..c449301abd 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -9486,3 +9486,25 @@ arbitrary precision floating point numbers, including transcendental
functions. To this end, the package interfaces with the @dfn{Multiple
Precision Floating-Point Reliable} (MPFR) library.")
(license license:gpl2+)))
+
+(define-public r-assertive-base
+ (package
+ (name "r-assertive-base")
+ (version "0.0-7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "assertive.base" version))
+ (sha256
+ (base32
+ "1xs3ysvj0z57c58jw57pckq2rynia6ks4rmjmc02alczhk54wbgh"))))
+ (properties
+ `((upstream-name . "assertive.base")))
+ (build-system r-build-system)
+ (home-page "https://bitbucket.org/richierocks/assertive.base")
+ (synopsis "Core of the assertive package")
+ (description
+ "This package provides a minimal set of predicates and assertions used by
+the assertive package. This is mainly for use by other package developers who
+want to include run-time testing features in their own packages.")
+ (license license:gpl3+)))