summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-09 15:31:02 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-09 15:43:50 +0100
commit2da2d2f60525ef87eb05753b093832f4ecd35f14 (patch)
treed30be327c8b2bdccaa352b0d404258bb430ca6f0 /gnu
parentdac9c1f6048237ecc0eeaa959b3c7429adb2518a (diff)
downloadguix-patches-2da2d2f60525ef87eb05753b093832f4ecd35f14.tar
guix-patches-2da2d2f60525ef87eb05753b093832f4ecd35f14.tar.gz
gnu: Add r-assertive-sets.
* gnu/packages/cran.scm (r-assertive-sets): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 270e402d40..70d87c9f66 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -9557,3 +9557,27 @@ testing features in their own packages.")
the properties of numbers. This is mainly for use by other package developers
who want to include run-time testing features in their own packages.")
(license license:gpl3+)))
+
+(define-public r-assertive-sets
+ (package
+ (name "r-assertive-sets")
+ (version "0.0-3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "assertive.sets" version))
+ (sha256
+ (base32
+ "1cqvh2syvh5b6d85h601zjmsdbbf3h8q98ids4dfl4frdshpasc7"))))
+ (properties
+ `((upstream-name . "assertive.sets")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-assertive-base" ,r-assertive-base)))
+ (home-page "https://bitbucket.org/richierocks/assertive.sets")
+ (synopsis "Assertions to check properties of sets")
+ (description
+ "This package provides a set of predicates and assertions for checking
+the properties of sets. This is mainly for use by other package developers
+who want to include run-time testing features in their own packages.")
+ (license license:gpl3+)))