summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-09 15:36:52 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-09 15:43:51 +0100
commit29d9a2affb7e876fbe620215da21e13d5d703927 (patch)
tree95dd04e38397dbad3f1ecc0a4ae2dd19b19e4856 /gnu
parent50ce8b1e2c83d0a31bba6dfaff1d5035d3a94892 (diff)
downloadguix-patches-29d9a2affb7e876fbe620215da21e13d5d703927.tar
guix-patches-29d9a2affb7e876fbe620215da21e13d5d703927.tar.gz
gnu: Add r-assertive-datetimes.
* gnu/packages/cran.scm (r-assertive-datetimes): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ee3852c99c..c8ad5edecc 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -9733,3 +9733,29 @@ packages.")
the properties of code. This is mainly for use by other package developers
who want to include run-time testing features in their own packages.")
(license license:gpl3+)))
+
+(define-public r-assertive-datetimes
+ (package
+ (name "r-assertive-datetimes")
+ (version "0.0-2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "assertive.datetimes" version))
+ (sha256
+ (base32
+ "00a98fx8p3pr3ckayh8wmxmm4rz01s67wah9697m92yci6pv3m78"))))
+ (properties
+ `((upstream-name . "assertive.datetimes")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-assertive-base" ,r-assertive-base)
+ ("r-assertive-types" ,r-assertive-types)))
+ (home-page "https://bitbucket.org/richierocks/assertive.datetimes")
+ (synopsis "Assertions to check properties of dates and times")
+ (description
+ "This package provides a set of predicates and assertions for checking
+the properties of dates and times. This is mainly for use by other package
+developers who want to include run-time testing features in their own
+packages.")
+ (license license:gpl3+)))