summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-09 15:35:14 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-09 15:43:51 +0100
commit1f0a761a14373cfec2baf7b79671ab221ea79845 (patch)
tree966f4dacc79f7fce4392be85b27d3ea0fb8ae1dc /gnu
parent5e3bd355069649e37eb52d2194e486d8419c51c6 (diff)
downloadguix-patches-1f0a761a14373cfec2baf7b79671ab221ea79845.tar
guix-patches-1f0a761a14373cfec2baf7b79671ab221ea79845.tar.gz
gnu: Add r-assertive-files.
* gnu/packages/cran.scm (r-assertive-files): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b3f45f38f0..158ee16179 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -9681,3 +9681,29 @@ want to include run-time testing features in their own packages.")
the types of variables. This is mainly for use by other package developers
who want to include run-time testing features in their own packages.")
(license license:gpl3+)))
+
+(define-public r-assertive-files
+ (package
+ (name "r-assertive-files")
+ (version "0.0-2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "assertive.files" version))
+ (sha256
+ (base32
+ "02pfz8j5vwcj5kl6zca46894li7lxwnlrr29j922f14ay6kdssmy"))))
+ (properties
+ `((upstream-name . "assertive.files")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-assertive-base" ,r-assertive-base)
+ ("r-assertive-numbers" ,r-assertive-numbers)))
+ (home-page "https://bitbucket.org/richierocks/assertive.files")
+ (synopsis "Assertions to check properties of files")
+ (description
+ "This package provides a set of predicates and assertions for checking
+the properties of files and connections. This is mainly for use by other
+package developers who want to include run-time testing features in their own
+packages.")
+ (license license:gpl3+)))