summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2021-09-20 19:37:50 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-09-21 13:50:53 +0000
commita3324e57531186a42feb3aa488556faa67386e9c (patch)
tree82fc0c1c24951a01739962b1cd5dc1f8d08ed80d /gnu
parentf762d63ec072500cd327ec5342c2f5434c267222 (diff)
downloadguix-patches-a3324e57531186a42feb3aa488556faa67386e9c.tar
guix-patches-a3324e57531186a42feb3aa488556faa67386e9c.tar.gz
gnu: 4dtris: Fix build.
* gnu/packages/games.scm (4dtris)[attributes]: Add -fcommon to CFLAGS and use search-input-directory to find SDL include path. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 88a589551d..e279e1eb71 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -8639,7 +8639,8 @@ affected by the gravity of the planets.")
"1nfkhcm0l89jyw8yr65na97g4l385zhjf7whkyg47c3v5sdqq2g7"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
+ `(#:configure-flags '("CFLAGS=-fcommon")
+ #:phases
(modify-phases %standard-phases
(add-after 'unpack 'fix-install-directories
(lambda* (#:key outputs #:allow-other-keys)
@@ -8656,7 +8657,7 @@ affected by the gravity of the planets.")
(lambda* (#:key inputs #:allow-other-keys)
(setenv "CPATH"
(string-append
- (search-input-file inputs "/include/SDL")
+ (search-input-directory inputs "/include/SDL")
":" (or (getenv "CPATH") ""))))))))
(inputs
`(("fontconfig" ,fontconfig)