summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-09-28 21:18:32 +0200
committerJulien Lepiller <julien@lepiller.eu>2021-10-08 03:31:32 +0200
commita0804f44456ee49e4c50130df0daf32aaf8f5281 (patch)
treeb7c3cd35598ed04fc4afafdde82d0fffdb4c20e6 /gnu
parent76177e816af239e32f9df7a2e764a7a1084cfc00 (diff)
downloadguix-patches-a0804f44456ee49e4c50130df0daf32aaf8f5281.tar
guix-patches-a0804f44456ee49e4c50130df0daf32aaf8f5281.tar.gz
gnu: ocaml-ctypes: Update to 0.19.1.
* gnu/packages/ocaml.scm (ocaml-ctypes): Update to 0.19.1. [arguments]<#:tests?>: Enable. <#phases>{make-writable}: Simplify. [inputs]: Remove ocaml-topkg and opam. Move ocaml-ounit and ocaml-lwt to ... [native-inputs]: ... here. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm25
1 files changed, 9 insertions, 16 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index dde02f2706..98846addf0 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4014,7 +4014,7 @@ long and size_t whose sizes depend on the host platform.")
(define-public ocaml-ctypes
(package
(name "ocaml-ctypes")
- (version "0.18.0")
+ (version "0.19.1")
(home-page "https://github.com/ocamllabs/ocaml-ctypes")
(source (origin
(method git-fetch)
@@ -4024,34 +4024,27 @@ long and size_t whose sizes depend on the host platform.")
(file-name (git-file-name name version))
(sha256
(base32
- "03zrbnl16m67ls0yfhq7a4k4238x6x6b3m456g4dw2yqwc153vks"))))
+ "1xi1a486gssrb23zln3sf7zn0rmyl1k684bdf9iqkhgpz607fq6s"))))
(build-system ocaml-build-system)
(arguments
- `(#:tests? #f; require an old lwt
- #:make-flags
+ `(#:make-flags
(list (string-append "INSTALL_HEADERS = $(wildcard $($(PROJECT).dir)/*.h)"))
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'make-writable
(lambda _
- (for-each
- (lambda (file)
- (let ((stat (stat file)))
- (chmod file (+ #o200 (stat:mode stat)))))
- (find-files "." "."))
- #t))
+ (for-each make-file-writable
+ (find-files "."))))
(delete 'configure))))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)
+ ("ounit" ,ocaml-ounit)
+ ("lwt" ,ocaml-lwt)))
(propagated-inputs
`(("bigarray-compat" ,ocaml-bigarray-compat)
("integers" ,ocaml-integers)))
(inputs
- `(("libffi" ,libffi)
- ("ounit" ,ocaml-ounit)
- ("lwt" ,ocaml-lwt)
- ("topkg" ,ocaml-topkg)
- ("opam" ,opam)))
+ `(("libffi" ,libffi)))
(synopsis "Library for binding to C libraries using pure OCaml")
(description "Ctypes is a library for binding to C libraries using pure
OCaml. The primary aim is to make writing C extensions as straightforward as